aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/grub2
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2016-11-17 18:25:52 +0200
committerFelix Fietkau <nbd@nbd.name>2016-12-20 16:24:21 +0100
commitb33845b2da7a02393f0814f161befa6cc2d5da7c (patch)
tree9bcf214ef8906a2f4d6fcca2df3131903e15fab7 /package/boot/grub2
parentf628d0e0e9adc5cf86a7d611e0d7c63cf6818188 (diff)
downloadupstream-b33845b2da7a02393f0814f161befa6cc2d5da7c.tar.gz
upstream-b33845b2da7a02393f0814f161befa6cc2d5da7c.tar.bz2
upstream-b33845b2da7a02393f0814f161befa6cc2d5da7c.zip
grub2: add PKG_FIXUP:=autoreconf
Reboot of: a0ea22ac430f91ab045431a79b2e2161e66cd56a Reverted: 3c52cbfa53056ded95ae5a7ae27319eafd5a37e5 The host-side build of grub2 requires this sometimes. This will re-generate the ./configure script from configure.ac. I don't know the conditions of how this reproduces, it just sometimes appears, and sometimes doesn't. Build error ``` <lede-dir>/build_dir/target-x86_64_musl-1.1.15_yogi/host/grub-2.02~beta2/build-aux/missing: line 81: aclocal-1.14: command not found WARNING: 'aclocal-1.14' is missing on your system. You should only need it if you modified 'acinclude.m4' or 'configure.ac' or m4 files included by 'configure.ac'. The 'aclocal' program is part of the GNU Automake package: <http://www.gnu.org/software/automake> It also requires GNU Autoconf, GNU m4 and Perl in order to run: <http://www.gnu.org/software/autoconf> <http://www.gnu.org/software/m4/> <http://www.perl.org/> Makefile:3962: recipe for target 'aclocal.m4' failed ``` Adding PKG_FIXUP adds sanity (i.e. autoreconf is used for host & target builds) over just using HOST_FIXUP. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'package/boot/grub2')
-rw-r--r--package/boot/grub2/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/boot/grub2/Makefile b/package/boot/grub2/Makefile
index 75f5e826c1..6b96e0a8d1 100644
--- a/package/boot/grub2/Makefile
+++ b/package/boot/grub2/Makefile
@@ -19,6 +19,7 @@ PKG_SOURCE_URL:=http://alpha.gnu.org/gnu/grub \
http://www.nic.funet.fi/pub/gnu/alpha/gnu/grub/
PKG_HASH:=f6c702b2a8ea58f27a2b02928bb77973cb5a827af08f63db38c471c0a01b418d
+PKG_FIXUP:=autoreconf
HOST_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=grub2/host