aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/at91bootstrap
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2018-05-04 10:27:47 -0700
committerJohn Crispin <john@phrozen.org>2018-05-05 06:55:21 +0200
commit22c398d2576b97b5afc67d6802528dc9eceb4d8a (patch)
tree647e6a2057c2441e178549223da07c27e056bbfe /package/boot/at91bootstrap
parent790b20b6f4744efaf91dd40292996cfb3c5cd8a5 (diff)
downloadupstream-22c398d2576b97b5afc67d6802528dc9eceb4d8a.tar.gz
upstream-22c398d2576b97b5afc67d6802528dc9eceb4d8a.tar.bz2
upstream-22c398d2576b97b5afc67d6802528dc9eceb4d8a.zip
at91: Add SAMA5D27 SOM1 EK board
Add support for SAMA5D27 SOM1 with target device as at91-sama5d27_som1_ek in SAMA5 subtarget and build images for SAMA5D27 SOM1 Ek board. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'package/boot/at91bootstrap')
-rw-r--r--package/boot/at91bootstrap/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/package/boot/at91bootstrap/Makefile b/package/boot/at91bootstrap/Makefile
index 8a1ec5e9c9..fbe44c424b 100644
--- a/package/boot/at91bootstrap/Makefile
+++ b/package/boot/at91bootstrap/Makefile
@@ -69,6 +69,21 @@ define AT91Bootstrap/sama5d4_xplainedsd_uboot_secure
BUILD_DEVICES:=at91-sama5d4_xplained
endef
+define AT91Bootstrap/sama5d27_som1_eksd_uboot
+ TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (SDcard0)
+ BUILD_DEVICES:=at91-sama5d27_som1_ek
+endef
+
+define AT91Bootstrap/sama5d27_som1_eksd1_uboot
+ TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (SDcard1)
+ BUILD_DEVICES:=at91-sama5d27_som1_ek
+endef
+
+define AT91Bootstrap/sama5d27_som1_ekqspi_uboot
+ TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (QSPI Flash)
+ BUILD_DEVICES:=at91-sama5d27_som1_ek
+endef
+
AT91BOOTSTRAP_TARGETS := \
sama5d2_xplaineddf_uboot \
sama5d2_xplaineddf_qspi_uboot \
@@ -77,7 +92,9 @@ AT91BOOTSTRAP_TARGETS := \
sama5d3_xplainedsd_uboot \
sama5d4_xplainednf_uboot_secure \
sama5d4_xplaineddf_uboot_secure \
- sama5d4_xplainedsd_uboot_secure
+ sama5d4_xplainedsd_uboot_secure \
+ sama5d27_som1_eksd_uboot \
+ sama5d27_som1_ekqspi_uboot
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \