aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/at91bootstrap
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2017-10-04 16:14:39 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2017-10-14 00:33:34 +0200
commitcc443e894a1b01093f5abba0c2884eb64c2f1778 (patch)
treea7835ece4590cd8d01467ca356ad79e33d476a47 /package/boot/at91bootstrap
parentc4f720b19a2699b577584f970254163853cea1d1 (diff)
downloadupstream-cc443e894a1b01093f5abba0c2884eb64c2f1778.tar.gz
upstream-cc443e894a1b01093f5abba0c2884eb64c2f1778.tar.bz2
upstream-cc443e894a1b01093f5abba0c2884eb64c2f1778.zip
at91bootstrap: Add BUILD_SUBTARGET variable
Added sama5 to BUILD_SUBTARGET variable.This will populate at91bootstrap menu options in bootloader menu only when SAMA5 devices are selected as SUBTARGET and to avoid showing up this menu when legacy device is selected as SUBTARGET and fixed typo mistake: sama5d3 -> sama5d2. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'package/boot/at91bootstrap')
-rw-r--r--package/boot/at91bootstrap/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/boot/at91bootstrap/Makefile b/package/boot/at91bootstrap/Makefile
index ae60fad445..4571fedc04 100644
--- a/package/boot/at91bootstrap/Makefile
+++ b/package/boot/at91bootstrap/Makefile
@@ -24,13 +24,14 @@ include $(INCLUDE_DIR)/package.mk
define AT91Bootstrap/Default
BUILD_TARGET:=at91
+ BUILD_SUBTARGET:=sama5
AT91BOOTSTRAP_IMAGE:=at91bootstrap.bin
endef
define at91bootstrap/sama5d2_xplaineddf_uboot
- TITLE:=AT91Bootstrap for the SAMA5D3 Xplained board (SPI Flash)
+ TITLE:=AT91Bootstrap for the SAMA5D2 Xplained board (SPI Flash)
BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=at91-sama5d3_xplained
+ BUILD_DEVICES:=at91-sama5d2_xplained
endef
define at91bootstrap/sama5d2_xplaineddf_qspi_uboot