aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/arm-trusted-firmware-mvebu
diff options
context:
space:
mode:
authorRobert Marko <robert.marko@sartura.hr>2022-09-21 18:40:59 +0200
committerRobert Marko <robert.marko@sartura.hr>2022-10-17 15:42:50 +0200
commitb58f3c573d9850e6da12bb0dec9445f20a55745d (patch)
tree5416d27d4f63c6d66cdbcde9a4129a72639d7ff8 /package/boot/arm-trusted-firmware-mvebu
parent1324fe468c0acece9f7c03a2d91a5bf2e6a9a9e0 (diff)
downloadupstream-b58f3c573d9850e6da12bb0dec9445f20a55745d.tar.gz
upstream-b58f3c573d9850e6da12bb0dec9445f20a55745d.tar.bz2
upstream-b58f3c573d9850e6da12bb0dec9445f20a55745d.zip
arm-trusted-firmware-mvebu: add Methode eDPU support
Provide ATF support for Methode eDPU as well, this makes it easy for OpenWrt users to update the included U-boot+ATF combo. Signed-off-by: Robert Marko <robert.marko@sartura.hr>
Diffstat (limited to 'package/boot/arm-trusted-firmware-mvebu')
-rw-r--r--package/boot/arm-trusted-firmware-mvebu/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/package/boot/arm-trusted-firmware-mvebu/Makefile b/package/boot/arm-trusted-firmware-mvebu/Makefile
index 3b7fd7a7cc..569d952cb8 100644
--- a/package/boot/arm-trusted-firmware-mvebu/Makefile
+++ b/package/boot/arm-trusted-firmware-mvebu/Makefile
@@ -97,6 +97,16 @@ define Trusted-Firmware-A/udpu
PLAT:=a3700
endef
+define Trusted-Firmware-A/edpu
+ NAME:=Methode eDPU
+ DEPENDS:=+u-boot-eDPU
+ BUILD_DEVICES:=methode_edpu
+ UBOOT:=eDPU
+ DDR_TOPOLOGY:=0
+ CLOCKSPRESET:=CPU_1000_DDR_800
+ PLAT:=a3700
+endef
+
TFA_TARGETS:= \
espressobin-512mb \
@@ -105,7 +115,8 @@ TFA_TARGETS:= \
espressobin-v3-v5-2gb \
espressobin-v7-1gb \
espressobin-v7-2gb \
- udpu
+ udpu \
+ edpu
TFA_MAKE_FLAGS += \
CROSS_CM3=$(BUILD_DIR)/$(CM3_GCC_NAME)-$(CM3_GCC_RELEASE)-$(CM3_GCC_VERSION)/bin/arm-none-eabi- \