aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/arm-trusted-firmware-mvebu
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2021-10-12 12:49:18 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-11-27 19:36:36 +0100
commitb18e87cc392a425f04a16b07293ec200ac751a51 (patch)
treeff469c31c3ec06ed17a92fa971bb89c38046a1a1 /package/boot/arm-trusted-firmware-mvebu
parent8d9f462731c887c65355d8a771a2adcb6453e28f (diff)
downloadupstream-b18e87cc392a425f04a16b07293ec200ac751a51.tar.gz
upstream-b18e87cc392a425f04a16b07293ec200ac751a51.tar.bz2
upstream-b18e87cc392a425f04a16b07293ec200ac751a51.zip
arm-trusted-firmware-mvebu: bump a3700-utils to current version
With cryptocpp in place we can now update past the point of dropping the old tbb_linux binary and build it instead. Hauke confirmed that this also allows this firmware to be built on aarch64. 97f01f5 Wtpdownloader: Properly retrieve current tty options a33ff86 Wtpdownloader: Set CREAD tty cflag af461d2 Wtpdownloader: Fix stuck during opening UART tty device 38c2135 Makefile: Print error when specified CLOCKSPRESET is not valid f014428 TBB: Remove out-of-dated x86-64 ELF binary tbb_linux 1b6cb50 TBB: Fix compilation with Crypto++ 5.6.5 d9fb291 TBB: Fix memory corruptions by calling correct delete[] operator d575885 TBB: Fix initializing CCTIM object b9e1c4e Wtpdownloader: Fix makefile 8f61591 Wtpdownloader: Fix building with gcc 11 eabea5f TBB: Fix building with gcc 11 Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/boot/arm-trusted-firmware-mvebu')
-rw-r--r--package/boot/arm-trusted-firmware-mvebu/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/boot/arm-trusted-firmware-mvebu/Makefile b/package/boot/arm-trusted-firmware-mvebu/Makefile
index 7735895df3..95d2c06a40 100644
--- a/package/boot/arm-trusted-firmware-mvebu/Makefile
+++ b/package/boot/arm-trusted-firmware-mvebu/Makefile
@@ -124,15 +124,15 @@ TFA_MAKE_FLAGS += \
mrvl_uart
A3700_UTILS_NAME:=a3700-utils
-A3700_UTILS_RELEASE:=2efdb10f
+A3700_UTILS_RELEASE:=97f01f5f
A3700_UTILS_SOURCE=$(A3700_UTILS_NAME)-$(A3700_UTILS_RELEASE).tar.bz2
define Download/a3700-utils
FILE:=$(A3700_UTILS_SOURCE)
PROTO:=git
URL:=https://github.com/MarvellEmbeddedProcessors/A3700-utils-marvell.git
- VERSION:=2efdb10f3524c534d276002adf81fec06e0f1cf2
- MIRROR_HASH:=4476e1bacfa7abb4a1303c6cf3aa7d067038b24090dfd5da13ca2a72a0d5c7a4
+ VERSION:=97f01f5feaf9ef6168e2a2096abaf56371939e58
+ MIRROR_HASH:=1e391c4dafb7b3363a17282e229d056a95575c0f4fb2f71e21db8044668aea78
SUBDIR:=$(A3700_UTILS_NAME)
endef