aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/arm-trusted-firmware-mvebu/patches/001-imagetool.patch
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2021-09-14 14:40:54 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-11-27 19:36:36 +0100
commit8d9f462731c887c65355d8a771a2adcb6453e28f (patch)
tree5c5ec41383c040485f1f7f18071188fe64033544 /package/boot/arm-trusted-firmware-mvebu/patches/001-imagetool.patch
parent35b0dc36a3f9af259a488c86abc892b1288dc00d (diff)
downloadupstream-8d9f462731c887c65355d8a771a2adcb6453e28f.tar.gz
upstream-8d9f462731c887c65355d8a771a2adcb6453e28f.tar.bz2
upstream-8d9f462731c887c65355d8a771a2adcb6453e28f.zip
arm-trusted-firmware-mvebu: add cryptopp
Based on the Build Instructions for Trusted-Firmware-A [1], there is a required cryptopp [2]. In the past, it used 'tbb_linux' image tool binary, which seems to be buggy, deprecated and removed from A3700-utils-marvell and it should not be used anymore. That's why I removed 001-imagetool.patch, which is no longer necessary. [1] https://trustedfirmware-a.readthedocs.io/en/v2.5/plat/marvell/armada/build.html [2] https://cryptopp.com/ Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'package/boot/arm-trusted-firmware-mvebu/patches/001-imagetool.patch')
-rw-r--r--package/boot/arm-trusted-firmware-mvebu/patches/001-imagetool.patch20
1 files changed, 0 insertions, 20 deletions
diff --git a/package/boot/arm-trusted-firmware-mvebu/patches/001-imagetool.patch b/package/boot/arm-trusted-firmware-mvebu/patches/001-imagetool.patch
deleted file mode 100644
index 1b4bb09c8c..0000000000
--- a/package/boot/arm-trusted-firmware-mvebu/patches/001-imagetool.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/plat/marvell/armada/a3k/common/a3700_common.mk
-+++ b/plat/marvell/armada/a3k/common/a3700_common.mk
-@@ -76,7 +76,7 @@ $(if $(wildcard $(value WTP)/*),,$(error
- $(if $(shell test -s "$(value WTP)/branch.txt" || git -C $(value WTP) rev-parse --show-cdup 2>&1),$(error "'WTP=$(value WTP)' was specified, but '$(value WTP)' does not contain valid Marvell a3700_utils release tarball nor git repository"))
-
- DOIMAGEPATH := $(WTP)
--DOIMAGETOOL := $(DOIMAGEPATH)/wtptp/src/TBB_Linux/release/TBB_linux
-+DOIMAGETOOL := $(DOIMAGEPATH)/wtptp/linux/tbb_linux
-
- BUILD_UART := uart-images
- UART_IMAGE := $(BUILD_UART).tgz.bin
-@@ -132,7 +132,7 @@ TIMBLDUARTARGS := $(MARVELL_SECURE_BOOT
- CRYPTOPP_LIBDIR ?= $(CRYPTOPP_PATH)
- CRYPTOPP_INCDIR ?= $(CRYPTOPP_PATH)
-
--$(DOIMAGETOOL): FORCE
-+$(DOIMAGETOOL):
- $(if $(CRYPTOPP_LIBDIR),,$(error "Platform '$(PLAT)' for WTP image tool requires CRYPTOPP_PATH or CRYPTOPP_LIBDIR. Please set CRYPTOPP_PATH or CRYPTOPP_LIBDIR to point to the right directory"))
- $(if $(CRYPTOPP_INCDIR),,$(error "Platform '$(PLAT)' for WTP image tool requires CRYPTOPP_PATH or CRYPTOPP_INCDIR. Please set CRYPTOPP_PATH or CRYPTOPP_INCDIR to point to the right directory"))
- $(if $(wildcard $(CRYPTOPP_LIBDIR)/*),,$(error "Either 'CRYPTOPP_PATH' or 'CRYPTOPP_LIB' was set to '$(CRYPTOPP_LIBDIR)', but '$(CRYPTOPP_LIBDIR)' does not exist"))