aboutsummaryrefslogtreecommitdiffstats
path: root/package/block-mount
diff options
context:
space:
mode:
authorDaniel Dickinson <daniel@cshore.neomailbox.net>2011-04-04 11:29:59 +0000
committerDaniel Dickinson <daniel@cshore.neomailbox.net>2011-04-04 11:29:59 +0000
commitf02b185301f3289d1c70a947bd86a9112052762d (patch)
treef8f50b93e9ccc31670ae5e8a0b19d2bab58fc57e /package/block-mount
parent6a533903e7b8833310e8ee346f3d102259020c4c (diff)
downloadupstream-f02b185301f3289d1c70a947bd86a9112052762d.tar.gz
upstream-f02b185301f3289d1c70a947bd86a9112052762d.tar.bz2
upstream-f02b185301f3289d1c70a947bd86a9112052762d.zip
[package] block-mount: Fixed warning of missing /lib/functions/fsck during boot when no scripts are installed in the directory. Thanks to Maarten Bezemer.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26468 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/block-mount')
-rw-r--r--package/block-mount/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/block-mount/Makefile b/package/block-mount/Makefile
index 05ca086d8e..ba19071b7b 100644
--- a/package/block-mount/Makefile
+++ b/package/block-mount/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=block-mount
PKG_VERSION:=0.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
include $(INCLUDE_DIR)/package.mk
@@ -51,6 +51,7 @@ define Package/block-mount/install
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DATA) ./files/fstab.config $(1)/etc/config/fstab
$(INSTALL_DIR) $(1)/lib/functions
+ $(INSTALL_DIR) $(1)/lib/functions/fsck
$(INSTALL_DATA) ./files/mount.sh $(1)/lib/functions/
$(INSTALL_DATA) ./files/fsck.sh $(1)/lib/functions/
$(INSTALL_DATA) ./files/block.sh $(1)/lib/functions/