aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2021-09-11 22:44:11 -1000
committerPaul Spooren <mail@aparcar.org>2021-09-23 21:39:46 -1000
commit9c331a6a91e870a1dc31f563333105e959f8b171 (patch)
tree190f2a1fb7b89f064dbc39cb6ea08436073ec1b2 /package/base-files
parent108901fffb66b60f307d959377852300caa8bbda (diff)
downloadupstream-9c331a6a91e870a1dc31f563333105e959f8b171.tar.gz
upstream-9c331a6a91e870a1dc31f563333105e959f8b171.tar.bz2
upstream-9c331a6a91e870a1dc31f563333105e959f8b171.zip
base-files: reduce `sed` calls
The `sed`-script shouldn't be called multiple times, especially not with the same files. This commit merges all files together in a single `sed`-script call. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 58ad08c63a..f87fd0fe6a 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -150,13 +150,11 @@ define Package/base-files/install
$(VERSION_SED_SCRIPT) \
$(1)/etc/banner \
+ $(1)/etc/device_info \
+ $(1)/etc/openwrt_release \
$(1)/etc/openwrt_version \
$(1)/usr/lib/os-release
- $(VERSION_SED_SCRIPT) \
- $(1)/etc/openwrt_release \
- $(1)/etc/device_info \
- $(1)/usr/lib/os-release
$(SED) "s#%PATH%#$(TARGET_INIT_PATH)#g" \
$(1)/sbin/hotplug-call \