aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2019-07-17 11:32:55 +0200
committerRafał Miłecki <rafal@milecki.pl>2019-07-22 14:27:37 +0200
commit790692dde2b9d1d07b9f46fe8397a043f83e79aa (patch)
tree162fa2791c6b9ae01ad40ab5b304c4d321b3c903 /package/base-files
parent1cbe0d659c4438cc6348093385a24e969aeadac0 (diff)
downloadupstream-790692dde2b9d1d07b9f46fe8397a043f83e79aa.tar.gz
upstream-790692dde2b9d1d07b9f46fe8397a043f83e79aa.tar.bz2
upstream-790692dde2b9d1d07b9f46fe8397a043f83e79aa.zip
base-files: drop support for the platform_nand_pre_upgrade()
No target uses it anymore. All code from that callback was moved into the platform_do_upgrade(). Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rw-r--r--package/base-files/files/lib/upgrade/nand.sh4
2 files changed, 1 insertions, 5 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 7c63d3ef44..49254a3680 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=base-files
-PKG_RELEASE:=204
+PKG_RELEASE:=205
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/lib/upgrade/nand.sh b/package/base-files/files/lib/upgrade/nand.sh
index 9f258a82c5..fbc2b5c19a 100644
--- a/package/base-files/files/lib/upgrade/nand.sh
+++ b/package/base-files/files/lib/upgrade/nand.sh
@@ -282,10 +282,6 @@ nand_upgrade_tar() {
nand_do_upgrade() {
local file_type=$(identify $1)
- if type 'platform_nand_pre_upgrade' >/dev/null 2>/dev/null; then
- platform_nand_pre_upgrade "$1"
- fi
-
[ ! "$(find_mtd_index "$CI_UBIPART")" ] && CI_UBIPART="rootfs"
case "$file_type" in