aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2008-07-30 17:09:01 +0000
committerJohn Crispin <blogic@openwrt.org>2008-07-30 17:09:01 +0000
commit5cee680b19d5447b0292d8535cc40440ac496d2b (patch)
treeb45983dfafd13f4e102408b6df8b407cacc1bc32 /package/base-files
parent56d57daef05a5e8be1752838c9979baff63a0858 (diff)
downloadupstream-5cee680b19d5447b0292d8535cc40440ac496d2b.tar.gz
upstream-5cee680b19d5447b0292d8535cc40440ac496d2b.tar.bz2
upstream-5cee680b19d5447b0292d8535cc40440ac496d2b.zip
creates a passwd's shadow file if busybox supports the feature, fixes #2887
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12017 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index f4ef55d110..231647e98b 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -147,6 +147,7 @@ define Package/base-files$(TARGET)/install
$(CP) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)/* $(1)/; \
fi \
)
+ $(if $(CONFIG_BUSYBOX_CONFIG_FEATURE_SHADOWPASSWDS),cp $(1)/etc/passwd $(1)/etc/shadow)
$(SED) 's,$$$$R,$(REVISION),g' $(1)/etc/banner
$(SED) 's,$$$$S,$(BOARD),g' -e 's,$$$$A,$(ARCH),g' $(1)/etc/ipkg.conf
mkdir -p $(1)/dev