aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-31 13:27:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-31 13:27:11 +0000
commitbab43e3269e2a1a2b7eb6aefe630b0aed735382f (patch)
treebd9f125e3e8f05731d074da6d17fe275a8c16377 /package/base-files
parent24c7f4cd0864361627e692df88f3a1c9e7ee2e79 (diff)
downloadupstream-bab43e3269e2a1a2b7eb6aefe630b0aed735382f.tar.gz
upstream-bab43e3269e2a1a2b7eb6aefe630b0aed735382f.tar.bz2
upstream-bab43e3269e2a1a2b7eb6aefe630b0aed735382f.zip
cleanup; change base-files build directory
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3858 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile22
1 files changed, 10 insertions, 12 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 536857657f..485ebddc3b 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -2,6 +2,16 @@
include $(TOPDIR)/rules.mk
+ifneq ($(DUMP),1)
+include $(BUILD_DIR)/kernel.mk
+include $(TOPDIR)/target/linux/rules.mk
+TARGET:=-$(BOARD)-$(KERNEL)
+BUILD_DIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
+
+UCLIBC_VERSION:=${shell cat $(STAGING_DIR)/uclibc_version}
+LIBGCC_VERSION:=${shell cat $(STAGING_DIR)/gcc_version}
+endif
+
PKG_NAME:=base-files
PKG_RELEASE:=8
PKG_BUILD_DIR:=$(BUILD_DIR)/base-files
@@ -13,15 +23,6 @@ endif
include $(TOPDIR)/package/rules.mk
-ifneq ($(DUMP),1)
-include $(BUILD_DIR)/kernel.mk
-include $(TOPDIR)/target/linux/rules.mk
-TARGET:=-$(BOARD)-$(KERNEL)
-
-UCLIBC_VERSION:=${shell cat $(STAGING_DIR)/uclibc_version}
-LIBGCC_VERSION:=${shell cat $(STAGING_DIR)/gcc_version}
-endif
-
CONFIG_PACKAGE_base-files$(TARGET):=CONFIG_PACKAGE_base-files
define Package/base-files$(TARGET)
@@ -99,9 +100,6 @@ $(call Package/base-files$(TARGET)/install-$(BOARD),$(1))
ln -sf /proc/mounts $(1)/etc/mtab
rm -f $(1)/var
ln -sf /tmp $(1)/var
- -find $(1) -type d -name CVS | xargs rm -rf
- -find $(1) -type d -name .svn | xargs rm -rf
- -find $(1) -name '.#*' | xargs rm -f
mkdir -p $(1)/etc
endef