aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorJoseph Tingiris <joseph.tingiris@gmail.com>2019-01-13 16:43:48 -0500
committerJo-Philipp Wich <jo@mein.io>2019-09-04 13:20:18 +0200
commit7c9213b8b399db84c553933b27814c563ae01112 (patch)
tree479d240c1b48ac993fd14183c43c28daf5e631f4 /package/base-files
parentdc10fd35f1800f9dd871b0018d412aeee9f095b8 (diff)
downloadupstream-7c9213b8b399db84c553933b27814c563ae01112.tar.gz
upstream-7c9213b8b399db84c553933b27814c563ae01112.tar.bz2
upstream-7c9213b8b399db84c553933b27814c563ae01112.zip
base-files: change boot & umount STOP indexes
This patch is in a series to allow additional STOP indexes after umount, so that other block devices may stop cleanly. boot is now STOP=90 umount is now STOP=90 After this patch series, the resulting STOP indexes in the 80s & 90s will be: STOP=85 odhcpd.init STOP=89 conntrackd.init STOP=89 log.init STOP=89 rssileds.init STOP=90 boot STOP=90 kdump.init STOP=90 network STOP=90 sysfixtime STOP=90 umount STOP=98 mdadm.init (note: will be addressed in a separate patch) Signed-off-by: Joseph Tingiris <joseph.tingiris@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [PKG_RELEASE is now 200] (cherry picked from commit 04811007e53c5a5bdddbd0a00b330e12a5dbd045)
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/etc/init.d/boot2
-rwxr-xr-xpackage/base-files/files/etc/init.d/umount2
3 files changed, 3 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index a6dee5aa5a..7129d488db 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=base-files
-PKG_RELEASE:=199
+PKG_RELEASE:=200
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/etc/init.d/boot b/package/base-files/files/etc/init.d/boot
index 31f245ffc7..09b7f44c79 100755
--- a/package/base-files/files/etc/init.d/boot
+++ b/package/base-files/files/etc/init.d/boot
@@ -2,7 +2,7 @@
# Copyright (C) 2006-2011 OpenWrt.org
START=10
-STOP=98
+STOP=90
uci_apply_defaults() {
. /lib/functions/system.sh
diff --git a/package/base-files/files/etc/init.d/umount b/package/base-files/files/etc/init.d/umount
index 349b2b3264..57a4a6d90c 100755
--- a/package/base-files/files/etc/init.d/umount
+++ b/package/base-files/files/etc/init.d/umount
@@ -1,7 +1,7 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2006 OpenWrt.org
-STOP=99
+STOP=90
stop() {
sync
/bin/umount -a -d -r