aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2012-12-27 14:10:01 +0000
committerSteven Barth <cyrus@openwrt.org>2012-12-27 14:10:01 +0000
commitf657787b52bbee6d435e9e87428cf69f22fe852f (patch)
tree6abe4319d33e611d0a48ec1b457dd47b56b094a9 /package/base-files
parent386c37b4c2b6b9bd7252ad21440bf85c4b67d377 (diff)
downloadupstream-f657787b52bbee6d435e9e87428cf69f22fe852f.tar.gz
upstream-f657787b52bbee6d435e9e87428cf69f22fe852f.tar.bz2
upstream-f657787b52bbee6d435e9e87428cf69f22fe852f.zip
base-files: Fix a typo in config_list_foreach
SVN-Revision: 34893
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/lib/functions.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 63350f822a..0e72c188d5 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=122
+PKG_RELEASE:=123
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/lib/functions.sh b/package/base-files/files/lib/functions.sh
index 54e69b8332..ae0257a5c5 100755
--- a/package/base-files/files/lib/functions.sh
+++ b/package/base-files/files/lib/functions.sh
@@ -197,7 +197,7 @@ config_list_foreach() {
[ -z "$len" ] && return 0
while [ $c -le "$len" ]; do
config_get val "${section}" "${option}_ITEM$c"
- eval "$function \"\$val\" \"$@\""
+ eval "$function \"\$val\" \"\$@\""
c="$(($c + 1))"
done
}