aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-10-05 07:40:25 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-10-05 07:40:25 +0000
commit978ecae6855efdd2806c2975b85b22c9b2833862 (patch)
tree56cd05febdfb8df94a96f24f6ccc171e6ae9a386 /package/base-files
parenta65975e0d681074629a6e27988c7a25b22b934cd (diff)
downloadupstream-978ecae6855efdd2806c2975b85b22c9b2833862.tar.gz
upstream-978ecae6855efdd2806c2975b85b22c9b2833862.tar.bz2
upstream-978ecae6855efdd2806c2975b85b22c9b2833862.zip
base-files: sysupgrade: merge info from "opkg list-changed-conffiles" to backup file list
SVN-Revision: 23233
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/sbin/sysupgrade5
2 files changed, 4 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index f290e79a06..9598823cb1 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=57
+PKG_RELEASE:=58
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/sbin/sysupgrade b/package/base-files/files/sbin/sysupgrade
index 0fb07530e4..1210e6e509 100755
--- a/package/base-files/files/sbin/sysupgrade
+++ b/package/base-files/files/sbin/sysupgrade
@@ -55,8 +55,9 @@ EOF
add_uci_conffiles() {
local file="$1"
- find /etc/config /etc/passwd /etc/group /etc/dropbear \
- /etc/firewall.user /etc/rc.local -type f > "$file"
+ ( find /etc/config /etc/passwd /etc/group /etc/dropbear \
+ /etc/firewall.user /etc/rc.local -type f;
+ opkg list-changed-conffiles ) | sort -u > "$file"
return 0
}