aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openwrt.org>2005-12-25 00:56:25 +0000
committerWaldemar Brodkorb <wbx@openwrt.org>2005-12-25 00:56:25 +0000
commite9d1bf5df5a1a4f155de9598890d7415f0632842 (patch)
tree762eff0236b25a171992b969982f9c9cc311471a /package/base-files
parentc323e9679a4336a73513be910a775f479ba5ec45 (diff)
downloadupstream-e9d1bf5df5a1a4f155de9598890d7415f0632842.tar.gz
upstream-e9d1bf5df5a1a4f155de9598890d7415f0632842.tar.bz2
upstream-e9d1bf5df5a1a4f155de9598890d7415f0632842.zip
change ipkg.conf to use snapshots
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2765 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile6
-rw-r--r--package/base-files/default/etc/ipkg.conf2
2 files changed, 7 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 16169fa28d..8b74ee0d9c 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -6,6 +6,11 @@ PKG_NAME:=base-files
PKG_RELEASE:=6
PKG_BUILD_DIR:=$(BUILD_DIR)/base-files
+BOARD:=$(shell LANG=C grep ^BR2_LINUX_2 $(TOPDIR)/.config|sed -e "s/=y//" \
+ -e "s/.*_//"| tr "[:upper:]" "[:lower:]")
+KERNEL:=$(shell LANG=C grep ^BR2_LINUX_2 $(TOPDIR)/.config|sed -e "s/=y//" \
+ -e "s/BR2_LINUX_//" -e "s/_BRCM//" -e "s/_/./"| tr "[:upper:]" "[:lower:]")
+
REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
ifeq ($(REV),)
REV:=0
@@ -40,6 +45,7 @@ $(IPKG_BASE):
$(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_BASE) ipkg/$(PKG_NAME).control $(PKG_RELEASE) $(ARCH)
cp -a ./default/* $(IDIR_BASE)
$(SED) 's,$$R,r$(REV),g' $(IDIR_BASE)/etc/banner
+ $(SED) 's,$$S,$(BOARD)-$(KERNEL),g' $(IDIR_BASE)/etc/ipkg.conf
mkdir -p $(IDIR_BASE)/jffs
mkdir -p $(IDIR_BASE)/dev
mkdir -p $(IDIR_BASE)/proc
diff --git a/package/base-files/default/etc/ipkg.conf b/package/base-files/default/etc/ipkg.conf
index 3867213313..2931d2cf80 100644
--- a/package/base-files/default/etc/ipkg.conf
+++ b/package/base-files/default/etc/ipkg.conf
@@ -1,3 +1,3 @@
-src experimental http://openwrt.org/downloads/experimental/bin/packages
+src snapshots http://openwrt.org/downloads/snapshots/$S/packages
dest root /
dest ram /tmp