aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-20 07:26:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-20 07:26:34 +0000
commitfd2da7768efe5b06c8f2bea9c3d740fac648668c (patch)
tree80df33c4b4b85bad213f8a6933d5e74ff3797f42 /package/base-files
parentf0f6a06c0ae0b8bce88182f95b0eead21ac68bb5 (diff)
downloadupstream-fd2da7768efe5b06c8f2bea9c3d740fac648668c.tar.gz
upstream-fd2da7768efe5b06c8f2bea9c3d740fac648668c.tar.bz2
upstream-fd2da7768efe5b06c8f2bea9c3d740fac648668c.zip
fix pthread mklibs relinking by copying libpthread_so.a from uclibc instead of using the standard _pic variant
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18090 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 4ee95aedfe..0fdbf11391 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -417,7 +417,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
endef
define Package/libc/install_lib
- $(CP) $(filter-out %/libdl_pic.a,$(wildcard $(TOOLCHAIN_DIR)/usr/lib/lib*.a)) $(1)/lib/
+ $(CP) $(filter-out %/libdl_pic.a %/libpthread_pic.a,$(wildcard $(TOOLCHAIN_DIR)/usr/lib/lib*.a)) $(1)/lib/
$(if $(wildcard $(TOOLCHAIN_DIR)/usr/lib/libc_so.a),$(CP) $(TOOLCHAIN_DIR)/usr/lib/libc_so.a $(1)/lib/libc_pic.a)
$(if $(wildcard $(TOOLCHAIN_DIR)/usr/lib/gcc/*/*/libgcc.map), \
$(CP) $(TOOLCHAIN_DIR)/usr/lib/gcc/*/*/libgcc_pic.a $(1)/lib/libgcc_s_pic.a; \
@@ -431,6 +431,10 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(CP) $(TOOLCHAIN_DIR)/lib/libpthread-$(LIBC_SO_VERSION).so $(1)/lib/
endef
+ define Package/libpthread/install_lib
+ $(if $(wildcard $(TOOLCHAIN_DIR)/usr/lib/libc_so.a),$(CP) $(TOOLCHAIN_DIR)/usr/lib/libpthread_so.a $(1)/lib/libpthread_pic.a)
+ endef
+
define Package/librt/install
$(INSTALL_DIR) $(1)/lib
$(CP) $(TOOLCHAIN_DIR)/lib/librt.so.* $(1)/lib/