aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-20 06:57:19 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-20 06:57:19 +0000
commitf0f6a06c0ae0b8bce88182f95b0eead21ac68bb5 (patch)
treef205e00d6eeb0785df33d85fb89ed4026ffcc66b /package/base-files
parent0996be22e7da68dbf3c91044b894edba5249ad4c (diff)
downloadupstream-f0f6a06c0ae0b8bce88182f95b0eead21ac68bb5.tar.gz
upstream-f0f6a06c0ae0b8bce88182f95b0eead21ac68bb5.tar.bz2
upstream-f0f6a06c0ae0b8bce88182f95b0eead21ac68bb5.zip
install the right version of libgcc along with its version map to fix relinking issues with mklibs, attempt to relink only if the version map is actually present
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18089 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index b288c0dfce..4ee95aedfe 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -419,7 +419,10 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
define Package/libc/install_lib
$(CP) $(filter-out %/libdl_pic.a,$(wildcard $(TOOLCHAIN_DIR)/usr/lib/lib*.a)) $(1)/lib/
$(if $(wildcard $(TOOLCHAIN_DIR)/usr/lib/libc_so.a),$(CP) $(TOOLCHAIN_DIR)/usr/lib/libc_so.a $(1)/lib/libc_pic.a)
- $(CP) $(TOOLCHAIN_DIR)/usr/lib/gcc/*/*/libgcc.a $(1)/lib/libgcc_s_pic.a
+ $(if $(wildcard $(TOOLCHAIN_DIR)/usr/lib/gcc/*/*/libgcc.map), \
+ $(CP) $(TOOLCHAIN_DIR)/usr/lib/gcc/*/*/libgcc_pic.a $(1)/lib/libgcc_s_pic.a; \
+ $(CP) $(TOOLCHAIN_DIR)/usr/lib/gcc/*/*/libgcc.map $(1)/lib/libgcc_s_pic.map \
+ )
endef
define Package/libpthread/install