aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-09-19 15:13:44 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-09-19 15:13:44 +0000
commit96117d3dce6a6405452065e1ae42d6012afa2bad (patch)
treea1b16d5d4b247faa2777fdd554e2f000feb6a237 /package/base-files
parent9f3edcb1bcca85b353d70f72171c50c862ca954c (diff)
downloadupstream-96117d3dce6a6405452065e1ae42d6012afa2bad.tar.gz
upstream-96117d3dce6a6405452065e1ae42d6012afa2bad.tar.bz2
upstream-96117d3dce6a6405452065e1ae42d6012afa2bad.zip
[package] base-files: release an attached loop device on umounting
Signed-off-by: Michael Heimpold <mhei@heimpold.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33477 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/etc/init.d/umount2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 13927528c0..1d56e9fc78 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=116
+PKG_RELEASE:=117
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/etc/init.d/umount b/package/base-files/files/etc/init.d/umount
index a4e477e2e9..5a750b93c6 100755
--- a/package/base-files/files/etc/init.d/umount
+++ b/package/base-files/files/etc/init.d/umount
@@ -4,5 +4,5 @@
STOP=99
stop() {
sync
- umount -a -r
+ umount -a -d -r
}