aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-09-17 17:15:56 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-09-17 17:15:56 +0000
commit365d9d069e15e144de09f9bb1ed7a77b3bab5128 (patch)
tree62c6528ccc4d5849220c5d50542883277795f925 /package/base-files
parent4ea95cae7d2e182daf804f8b29f303b455b53cea (diff)
downloadupstream-365d9d069e15e144de09f9bb1ed7a77b3bab5128.tar.gz
upstream-365d9d069e15e144de09f9bb1ed7a77b3bab5128.tar.bz2
upstream-365d9d069e15e144de09f9bb1ed7a77b3bab5128.zip
[package] base-files: add uci-defaults script to migrate sysctl.conf (#12196)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33448 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rw-r--r--package/base-files/files/etc/uci-defaults/migrate-sysctl17
2 files changed, 18 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 50ad7d4a0c..13927528c0 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=115
+PKG_RELEASE:=116
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/etc/uci-defaults/migrate-sysctl b/package/base-files/files/etc/uci-defaults/migrate-sysctl
new file mode 100644
index 0000000000..2250c57802
--- /dev/null
+++ b/package/base-files/files/etc/uci-defaults/migrate-sysctl
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+if [ ! -f "/rom/etc/sysctl.conf" ] || cmp "/rom/etc/sysctl.conf" "/etc/sysctl.conf"; then
+ exit 0
+fi
+
+fingerprint="$(md5sum /etc/sysctl.conf)"
+fingerprint="${fingerprint%% *}"
+
+if [ "$fingerprint" = "1b05ebb41f72cb84e5510573cd4aca26" ] || \
+ [ "$fingerprint" = "62deb895be1a7f496040187b7c930e4e" ]; then
+ logger -t migrate-sysctl "Updating sysctl.conf to use current defaults"
+ cp "/rom/etc/sysctl.conf" "/etc/sysctl.conf"
+fi
+
+exit 0
+