aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2021-07-30 01:11:37 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2021-08-07 01:34:40 +0300
commit8347d8b4fbe41ce7db386f948df3ebb6c6bc32d3 (patch)
tree506c3ab13d248558ed9c5dbd7e34d5c641c07262 /package/base-files/Makefile
parent84c9570aaadec70b667586c3c84dd9fd095baa9e (diff)
downloadupstream-8347d8b4fbe41ce7db386f948df3ebb6c6bc32d3.tar.gz
upstream-8347d8b4fbe41ce7db386f948df3ebb6c6bc32d3.tar.bz2
upstream-8347d8b4fbe41ce7db386f948df3ebb6c6bc32d3.zip
base-files: add generic sdcard upgrade method
Add a generic sdcard upgrade method instead of duplicating code in yet another target, and add a feature flag to only install this upgrade method in targets that set this flag. Copied from mvebu. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 5f816a0d1b..f19b07cfe1 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -23,6 +23,7 @@ PKG_LICENSE:=GPL-2.0
PKG_CONFIG_DEPENDS += \
CONFIG_SIGNED_PACKAGES CONFIG_TARGET_INIT_PATH CONFIG_TARGET_PREINIT_DISABLE_FAILSAFE \
CONFIG_NAND_SUPPORT \
+ CONFIG_SDCARD_SUPPORT \
CONFIG_CLEAN_IPKG \
CONFIG_PER_FEED_REPO \
$(foreach feed,$(FEEDS_AVAILABLE),CONFIG_FEED_$(feed))
@@ -123,10 +124,18 @@ ifeq ($(CONFIG_NAND_SUPPORT),)
endef
endif
+ifeq ($(CONFIG_SDCARD_SUPPORT),)
+ define Package/base-files/sdcard-support
+ rm -f $(1)/lib/upgrade/sdcard.sh
+ endef
+endif
+
+
define Package/base-files/install
$(CP) ./files/* $(1)/
$(Package/base-files/install-key)
$(Package/base-files/nand-support)
+ $(Package/base-files/sdcard-support)
if [ -d $(GENERIC_PLATFORM_DIR)/base-files/. ]; then \
$(CP) $(GENERIC_PLATFORM_DIR)/base-files/* $(1)/; \
fi