aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-07-29 13:30:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-07-29 13:30:23 +0000
commitd5653558ac0044824974c7e73d349e4b2747e3ab (patch)
treed21e3225d3c667afe726dd2c24592acd58ece1a0 /package/base-files/Makefile
parentdbb77e39a07a86b18ecc4ce27bb2841e0a099c9d (diff)
downloadupstream-d5653558ac0044824974c7e73d349e4b2747e3ab.tar.gz
upstream-d5653558ac0044824974c7e73d349e4b2747e3ab.tar.bz2
upstream-d5653558ac0044824974c7e73d349e4b2747e3ab.zip
base-files: properly escape strings for version info
Make sure they don't break the sed command, and also make device_info and openwrt_release more robust for parsing by scripts Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 41885
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 76a4dabe0e..10724b3eac 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -110,7 +110,9 @@ define Package/base-files/install
$(VERSION_SED) \
$(1)/etc/banner \
- $(1)/etc/openwrt_version \
+ $(1)/etc/openwrt_version
+
+ $(VERSION_SED_SCRIPT) \
$(1)/etc/openwrt_release \
$(1)/etc/device_info