aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-12 11:09:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-12 11:09:05 +0000
commitb2e87f2906d23b27b15f002ab41e7650dec6962f (patch)
tree025d39afe858e1a8d8ae6c11cbab3ae31f9effd2 /package/base-files/Makefile
parent916382168371178c24cd4b9550b200f940496131 (diff)
downloadupstream-b2e87f2906d23b27b15f002ab41e7650dec6962f.tar.gz
upstream-b2e87f2906d23b27b15f002ab41e7650dec6962f.tar.bz2
upstream-b2e87f2906d23b27b15f002ab41e7650dec6962f.zip
Fix the annoying base-files autorebuild bug.
When checking file mtimes in directories, timestamp.pl was following symlinks. This broke on base-files, because there are symlinks to /tmp and to /proc/mounts in the build directory. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6084 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 14917f683b..33e6522e7e 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -13,6 +13,7 @@ PKG_NAME:=base-files
PKG_RELEASE:=8
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)
+PKG_FILE_DEPEND:=$(PLATFORM_DIR)
REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
ifeq ($(REV),)