aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-05-18 09:50:06 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-05-18 09:50:06 +0000
commited8f726dabb07a11215c692b0887a14d8f2b55e4 (patch)
tree5f99b523e9f0ada4e9def70c9870e97c5cb379ea /package/base-files/Makefile
parente35822050ba289a4e6db91d9e72c9504f84fee97 (diff)
downloadupstream-ed8f726dabb07a11215c692b0887a14d8f2b55e4.tar.gz
upstream-ed8f726dabb07a11215c692b0887a14d8f2b55e4.tar.bz2
upstream-ed8f726dabb07a11215c692b0887a14d8f2b55e4.zip
ipcalc.sh CIDR notation Hi,
the attached patch makes ipcalc.sh accept IP/Netmask combinations in CIDR notation. Before you could only do: # sh ipcalc.sh 192.168.0.0 255.255.255.0 1 10 IP=192.168.0.0 NETMASK=255.255.255.0 BROADCAST=192.168.0.255 NETWORK=192.168.0.0 PREFIX=24 START=192.168.0.1 END=192.168.0.11 with this patch you can also execute it with: sh ipcalc.sh 192.168.0.0/24 1 10 IP=192.168.0.0 NETMASK=255.255.255.0 BROADCAST=192.168.0.255 NETWORK=192.168.0.0 PREFIX=24 START=192.168.0.1 END=192.168.0.11 The patch is based on #1260 [1], i just changed one line to calculate the START end END ips right. I wonder why that never got included. If there is no reason not to do i would like to ask you to commit that patch, because its a functionality i (and probably others) miss quite often. Btw, i also fixed 4 useless tabs, that might look a bit strange in the patch. Regards, Manuel SVN-Revision: 26930
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index c10f483270..3d179aed09 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=69
+PKG_RELEASE:=70
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host