aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-09-26 02:28:04 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-09-26 02:28:04 +0000
commitbfbbe5893f92cd572c48c4d37fbd975f148093d6 (patch)
tree326e5b8b8c653c5ef864431a3b7fe3fcbaf927b6 /package/base-files/Makefile
parent29123aee6d3830161d1531d8487c8195d8df2f4f (diff)
downloadupstream-bfbbe5893f92cd572c48c4d37fbd975f148093d6.tar.gz
upstream-bfbbe5893f92cd572c48c4d37fbd975f148093d6.tar.bz2
upstream-bfbbe5893f92cd572c48c4d37fbd975f148093d6.zip
base-files: use "zonename" system option to symlink /etc/localtime via /tmp/localtime to /usr/share/zoneinfo for glibc and eglibc
SVN-Revision: 28306
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 775126aa53..713dd7fad5 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=80
+PKG_RELEASE:=81
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
@@ -513,6 +513,8 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
define Package/glibc/install
$(CP) ./glibc-files/* $(1)/
+ rm -f $(1)/etc/localtime
+ ln -sf /tmp/localtime $(1)/etc/localtime
$(INSTALL_DIR) $(1)/lib
$(CP) \
$(TOOLCHAIN_DIR)/lib/ld*.so.* \