aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-09-29 14:27:54 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-09-29 14:27:54 +0000
commit9233c3cdb934c97f06168a0ad51379806fef5ae0 (patch)
tree68991157c40028c3c75e338767cc54f5effa8190 /package/base-files/Makefile
parentc4d5ba64e414d98d01c15e0cf0c88072907702cf (diff)
downloadupstream-9233c3cdb934c97f06168a0ad51379806fef5ae0.tar.gz
upstream-9233c3cdb934c97f06168a0ad51379806fef5ae0.tar.bz2
upstream-9233c3cdb934c97f06168a0ad51379806fef5ae0.zip
get rid of per-profile base-files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9069 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile17
1 files changed, 6 insertions, 11 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index d81ec4f1c4..f5bf1adce7 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -130,19 +130,14 @@ define Package/base-files$(TARGET)/install
if [ -d $(GENERIC_PLATFORM_DIR)/base-files/. ]; then \
$(CP) $(GENERIC_PLATFORM_DIR)/base-files/* $(1)/; \
fi
- if [ -d $(PLATFORM_DIR)/base-files/default/. ]; then \
- $(CP) $(PLATFORM_DIR)/base-files/default/* $(1)/; \
+ if [ -d $(PLATFORM_DIR)/base-files/. ]; then \
+ $(CP) $(PLATFORM_DIR)/base-files/* $(1)/; \
fi
$(if $(filter-out $(PLATFORM_DIR),$(PLATFORM_SUBDIR)), \
- if [ -d $(PLATFORM_SUBDIR)/base-files/default/. ]; then \
- $(CP) $(PLATFORM_SUBDIR)/base-files/default/* $(1)/; \
+ if [ -d $(PLATFORM_SUBDIR)/base-files/. ]; then \
+ $(CP) $(PLATFORM_SUBDIR)/base-files/* $(1)/; \
fi \
)
- if [ "$(PROFILE)" != "Default" ]; then \
- if [ -d $(PLATFORM_DIR)/base-files/profile-$(PROFILE)/. ]; then \
- $(CP) $(PLATFORM_DIR)/base-files/profile-$(PROFILE)/* $(1)/; \
- fi; \
- fi
$(SED) 's,$$$$R,r$(REV),g' $(1)/etc/banner
$(SED) 's,$$$$S,$(BOARD)-$(KERNEL),g' -e 's,$$$$A,$(ARCH),g' $(1)/etc/ipkg.conf
mkdir -p $(1)/dev