aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-07-29 13:30:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-07-29 13:30:23 +0000
commit02627475b95042953a2202d420e1b3cd707d072d (patch)
treecf0dab6665c3d91ae4a30787e104f4c968b4986b /package/base-files/Makefile
parent5198a23da8047a6df214544b46a4b57a9addf8b6 (diff)
downloadupstream-02627475b95042953a2202d420e1b3cd707d072d.tar.gz
upstream-02627475b95042953a2202d420e1b3cd707d072d.tar.bz2
upstream-02627475b95042953a2202d420e1b3cd707d072d.zip
base-files: properly escape strings for version info
Make sure they don't break the sed command, and also make device_info and openwrt_release more robust for parsing by scripts Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41885 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 76a4dabe0e..10724b3eac 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -110,7 +110,9 @@ define Package/base-files/install
$(VERSION_SED) \
$(1)/etc/banner \
- $(1)/etc/openwrt_version \
+ $(1)/etc/openwrt_version
+
+ $(VERSION_SED_SCRIPT) \
$(1)/etc/openwrt_release \
$(1)/etc/device_info