aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-08 12:48:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-08 12:48:36 +0000
commit99f5adbf5502377197cb75281ee4f60241f66072 (patch)
treedfde2a389ffae4beadef1a07288000d670b72ff6 /package/base-files/Makefile
parentc1cfca24f9ec6c503a73f8fbc857b5fe45ae6794 (diff)
downloadupstream-99f5adbf5502377197cb75281ee4f60241f66072.tar.gz
upstream-99f5adbf5502377197cb75281ee4f60241f66072.tar.bz2
upstream-99f5adbf5502377197cb75281ee4f60241f66072.zip
base-files: the relinked libpthread needs to be linked against libdl, otherwise calls to dlopen() fail (fixes #8978)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25950 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 61296b05ef..07cc8b460a 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -357,7 +357,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
"$(wildcard $(TOOLCHAIN_DIR)/lib/libpthread_so.a)" \
"$(patsubst $(TOOLCHAIN_DIR)/lib/%,$(PKG_BUILD_DIR)/%,$(wildcard $(TOOLCHAIN_DIR)/lib/libpthread-*.so))" \
-Wl,-z,nodelete,-z,initfirst,-init=__pthread_initialize_minimal_internal \
- $(BUILD_LIBGCC) \
+ -ldl $(BUILD_LIBGCC) \
-Wl,-soname=libpthread.so.0
endef
ifneq ($(BUILD_LIBGCC),)