aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-03 22:03:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-03 22:03:50 +0000
commitf487e44bbb5964808f5a847eb970cd943c6bf68a (patch)
treea3b14c1c179be87fb786d4a911daa3116be3286d /package/base-files/Makefile
parent4ca4bc2da95529becc5e8cb021cb4a6b28da3182 (diff)
downloadupstream-f487e44bbb5964808f5a847eb970cd943c6bf68a.tar.gz
upstream-f487e44bbb5964808f5a847eb970cd943c6bf68a.tar.bz2
upstream-f487e44bbb5964808f5a847eb970cd943c6bf68a.zip
rename the <boardname>-<kernelversion> directories of base-files to just <boardname>, so that the broadcom stuff can share files across kernel versions. adding back <boardname>-<kernelversion> for version specific overrides is still possible
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5427 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 9f6da3bc7c..f778219665 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -143,6 +143,9 @@ endef
define Package/base-files$(TARGET)/install
$(CP) ./default/* $(1)/
+ if [ -d $(BOARD) ]; then \
+ $(CP) $(BOARD)/* $(1)/; \
+ fi
if [ -d $(BOARD)-$(KERNEL) ]; then \
$(CP) $(BOARD)-$(KERNEL)/* $(1)/; \
fi