aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
commit5a325930579db5f9175bea19459c845746801ae4 (patch)
tree8b63e203323c3c4ab05aa9bf0a9ec17f5dc87c91 /package/base-files/Makefile
parent7bc567a0409f4d9aa9a4e12e9c56bc892b737da3 (diff)
downloadupstream-5a325930579db5f9175bea19459c845746801ae4.tar.gz
upstream-5a325930579db5f9175bea19459c845746801ae4.tar.bz2
upstream-5a325930579db5f9175bea19459c845746801ae4.zip
replace lots of manual install commands with INSTALL_* variables
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5624 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 6285929436..16c6dc1eb8 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -125,18 +125,18 @@ define Package/base-files$(TARGET)/install
endef
define Package/libgcc/install
- install -m0755 -d $(1)/lib
+ $(INSTALL_DIR) $(1)/lib
$(CP) $(STAGING_DIR)/lib/libgcc_s.so.* $(1)/lib/
endef
define Package/libpthread/install
- install -m0755 -d $(1)/lib
+ $(INSTALL_DIR) $(1)/lib
$(CP) $(STAGING_DIR)/lib/libpthread.so.* $(1)/lib/
$(CP) $(STAGING_DIR)/lib/libpthread-$(UCLIBC_VERSION).so $(1)/lib/
endef
define Package/uclibc/install
- install -m0755 -d $(1)/lib
+ $(INSTALL_DIR) $(1)/lib
for file in ld-uClibc libc libcrypt libdl libm libnsl libresolv librt libuClibc libutil; do \
$(CP) $(STAGING_DIR)/lib/$$$$file.so.* $(1)/lib/; \
$(CP) $(STAGING_DIR)/lib/$$$$file-$(UCLIBC_VERSION).so $(1)/lib/; \