aboutsummaryrefslogtreecommitdiffstats
path: root/package/arptables
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-05-12 18:29:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-05-12 18:29:12 +0000
commit0d093a375f233e8f1e777dca78619c2504c22a81 (patch)
treeb896470babc280fca1024eb1161b82537f98d76a /package/arptables
parenta2d19bba0b832926c67c20de2520f40b4f4a743c (diff)
downloadupstream-0d093a375f233e8f1e777dca78619c2504c22a81.tar.gz
upstream-0d093a375f233e8f1e777dca78619c2504c22a81.tar.bz2
upstream-0d093a375f233e8f1e777dca78619c2504c22a81.zip
convert arptables to new packaging style
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@839 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/arptables')
-rw-r--r--package/arptables/Makefile33
-rw-r--r--package/arptables/ipkg/arptables.control (renamed from package/arptables/arptables.control)0
2 files changed, 7 insertions, 26 deletions
diff --git a/package/arptables/Makefile b/package/arptables/Makefile
index baa2dc3005..e770fef590 100644
--- a/package/arptables/Makefile
+++ b/package/arptables/Makefile
@@ -13,36 +13,17 @@ PKG_SOURCE_URL:=@SF/ebtables
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
PKG_CAT:=zcat
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
-$(DL_DIR)/$(PKG_SOURCE):
- $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+include $(TOPDIR)/package/rules.mk
-$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
- $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- touch $(PKG_BUILD_DIR)/.unpacked
+$(eval $(call PKG_template,ARPTABLES,arptables,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(PKG_BUILD_DIR)/arptables: $(PKG_BUILD_DIR)/.unpacked
+$(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR) \
CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
CFLAGS="$(TARGET_CFLAGS) -Wall -I$(PKG_BUILD_DIR)/include/linux/include -I$(PKG_BUILD_DIR)/include -DARPTABLES_VERSION=\\\"$(PKG_VERSION)\\\" "
-$(PKG_IPK): $(PKG_BUILD_DIR)/arptables
- $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
- mkdir -p $(PKG_IPK_DIR)/usr/sbin
- cp $(PKG_BUILD_DIR)/arptables $(PKG_IPK_DIR)/usr/sbin/
- mkdir -p $(PACKAGE_DIR)
- $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-
-$(IPKG_STATE_DIR)/info/arptables.list: $(PKG_IPK)
- $(IPKG) install $(PKG_IPK)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.unpacked
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/arptables.list
-
-clean:
- rm -rf $(PKG_BUILD_DIR)
- rm -f $(PKG_IPK)
+$(IPKG_ARPTABLES):
+ mkdir -p $(IDIR_ARPTABLES)/usr/sbin
+ cp $(PKG_BUILD_DIR)/arptables $(IDIR_ARPTABLES)/usr/sbin/
+ $(IPKG_BUILD) $(IDIR_ARPTABLES) $(PACKAGE_DIR)
diff --git a/package/arptables/arptables.control b/package/arptables/ipkg/arptables.control
index 0266e69ea0..0266e69ea0 100644
--- a/package/arptables/arptables.control
+++ b/package/arptables/ipkg/arptables.control