aboutsummaryrefslogtreecommitdiffstats
path: root/package/ar7-atm
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-01-07 19:38:17 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-01-07 19:38:17 +0000
commit0fb0428c731487c62d3ca240c4c68534efec4c32 (patch)
tree6df757a7bd08cbbebdbbc7a08a1ac608e47e6dd6 /package/ar7-atm
parentf548f984074e7bfee7567c58dfcdc6184e9b010d (diff)
downloadupstream-0fb0428c731487c62d3ca240c4c68534efec4c32.tar.gz
upstream-0fb0428c731487c62d3ca240c4c68534efec4c32.tar.bz2
upstream-0fb0428c731487c62d3ca240c4c68534efec4c32.zip
Hi all, here is a patch for package/ar7-atm. It fixes the bug #2377,
which reports a WARNING: at kernel/softirq.c:138 local_bh_enable(). Make the TIATM driver use tasklet, instead of BH without the flag, the TIATM driver treats packets inside BH, which is wrong for most skbuff stuff. Use tasklet instead. Signed-off-by: <benoit.ganne@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10141 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ar7-atm')
-rw-r--r--package/ar7-atm/patches/150-tasklet_mode.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/ar7-atm/patches/150-tasklet_mode.patch b/package/ar7-atm/patches/150-tasklet_mode.patch
new file mode 100644
index 0000000000..c8dc82fadb
--- /dev/null
+++ b/package/ar7-atm/patches/150-tasklet_mode.patch
@@ -0,0 +1,12 @@
+diff -Naur sangam_atm-D7.03.01.00.orig/Makefile sangam_atm-D7.03.01.00/Makefile
+--- sangam_atm-D7.03.01.00.orig/Makefile       2008-01-07 10:30:34.000000000 +0100
++++ sangam_atm-D7.03.01.00/Makefile    2008-01-07 10:31:40.000000000 +0100
+@@ -5,6 +5,7 @@
+ CONFIG_SANGAM_ATM=m
+ #EXTRA_CFLAGS += -DEL -I. -DPOST_SILICON -DCOMMON_NSP -DCONFIG_LED_MODULE -DDEREGISTER_LED -DNO_ACT
+ #EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -DNO_ACT -D__NO__VOICE_PATCH__ -DEL
+-EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -D__NO__VOICE_PATCH__ -DEL
++#EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -D__NO__VOICE_PATCH__ -DEL
++EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -D__NO__VOICE_PATCH__ -DEL -DCPATM_TASKLET_MODE
+ obj-$(CONFIG_SANGAM_ATM) := tiatm.o
+ tiatm-objs += cpsar.o aal5sar.o tn7sar.o tn7atm.o tn7dsl.o dsl_hal_api.o dsl_hal_support.o dsl_hal_advcfg.o