aboutsummaryrefslogtreecommitdiffstats
path: root/package/ar7-atm/patches/130-powercutback.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-03-07 18:16:07 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-03-07 18:16:07 +0000
commitc7658c8664a2de8fec2f853734604d0fa8c7849f (patch)
tree536c8e0e370a4c6e1d26385196448b315f072e3c /package/ar7-atm/patches/130-powercutback.patch
parente3062cbd6e8b995326e06ec433003f1321409f39 (diff)
downloadupstream-c7658c8664a2de8fec2f853734604d0fa8c7849f.tar.gz
upstream-c7658c8664a2de8fec2f853734604d0fa8c7849f.tar.bz2
upstream-c7658c8664a2de8fec2f853734604d0fa8c7849f.zip
[ar7] add support for new ar7-atm version D7.05.00.00 (#6515)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20039 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ar7-atm/patches/130-powercutback.patch')
-rw-r--r--package/ar7-atm/patches/130-powercutback.patch44
1 files changed, 0 insertions, 44 deletions
diff --git a/package/ar7-atm/patches/130-powercutback.patch b/package/ar7-atm/patches/130-powercutback.patch
deleted file mode 100644
index ec00df97ab..0000000000
--- a/package/ar7-atm/patches/130-powercutback.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/dsl_hal_advcfg.c
-+++ b/dsl_hal_advcfg.c
-@@ -36,9 +36,9 @@
- * 05Jul05 0.00.09 CPH CQ9775: Change dslhal_advcfg_configDsTones input parameters & support for ADSL2+
- * 24Jul05 0.00.10 CPH Fixed comments in dslhal_advcfg_configDsTones function header
- *******************************************************************************/
--#include <dev_host_interface.h>
--#include <dsl_hal_register.h>
--#include <dsl_hal_support.h>
-+#include "dev_host_interface.h"
-+#include "dsl_hal_register.h"
-+#include "dsl_hal_support.h"
-
- /*****************************************************************************/
- /* ACT API functions -- To be moved into their own independent module --RamP */
---- a/Makefile
-+++ b/Makefile
-@@ -4,6 +4,7 @@
-
- CONFIG_SANGAM_ATM=m
- #EXTRA_CFLAGS += -DEL -I. -DPOST_SILICON -DCOMMON_NSP -DCONFIG_LED_MODULE -DDEREGISTER_LED -DNO_ACT
--EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -DNO_ACT -D__NO__VOICE_PATCH__ -DEL
-+#EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -DNO_ACT -D__NO__VOICE_PATCH__ -DEL
-+EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -D__NO__VOICE_PATCH__ -DEL
- obj-$(CONFIG_SANGAM_ATM) := tiatm.o
--tiatm-objs += cpsar.o aal5sar.o tn7sar.o tn7atm.o tn7dsl.o dsl_hal_api.o dsl_hal_support.o
-+tiatm-objs += cpsar.o aal5sar.o tn7sar.o tn7atm.o tn7dsl.o dsl_hal_api.o dsl_hal_support.o dsl_hal_advcfg.o
---- a/tn7dsl.c
-+++ b/tn7dsl.c
-@@ -2869,6 +2869,14 @@ static int tn7dsl_set_dsl(void)
- dslhal_api_setRateAdaptFlag(pIhw, os_atoi(ptr));
- }
-
-+ // set powercutback
-+ ptr = NULL;
-+ ptr = prom_getenv("powercutback");
-+ if(ptr)
-+ {
-+ dslhal_advcfg_onOffPcb(pIhw, os_atoi(ptr));
-+ }
-+
- // trellis
- ptr = NULL;
- ptr = prom_getenv("trellis");