aboutsummaryrefslogtreecommitdiffstats
path: root/package/ar7-atm/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-03-07 18:16:07 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-03-07 18:16:07 +0000
commitc7658c8664a2de8fec2f853734604d0fa8c7849f (patch)
tree536c8e0e370a4c6e1d26385196448b315f072e3c /package/ar7-atm/Makefile
parente3062cbd6e8b995326e06ec433003f1321409f39 (diff)
downloadupstream-c7658c8664a2de8fec2f853734604d0fa8c7849f.tar.gz
upstream-c7658c8664a2de8fec2f853734604d0fa8c7849f.tar.bz2
upstream-c7658c8664a2de8fec2f853734604d0fa8c7849f.zip
[ar7] add support for new ar7-atm version D7.05.00.00 (#6515)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20039 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ar7-atm/Makefile')
-rw-r--r--package/ar7-atm/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/ar7-atm/Makefile b/package/ar7-atm/Makefile
index 88036c6939..e5cef07910 100644
--- a/package/ar7-atm/Makefile
+++ b/package/ar7-atm/Makefile
@@ -10,16 +10,25 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=sangam_atm
+ifeq ($(CONFIG_AR7_ATM_FW_VERSION_705),y)
+PKG_VERSION:=D7.05.01.00
+PKG_MD5SUM:=42ee465be5cfbe9476fc25deb260d450
+PKG_RELEASE:=R1
+PATCH_DIR:=patches-$(PKG_VERSION)
+endif
+
ifeq ($(CONFIG_AR7_ATM_FW_VERSION_704),y)
PKG_VERSION:=D7.04.03.00
PKG_MD5SUM:=3d76004e46f09e88931f91670cb420ad
PKG_RELEASE:=R1
+PATCH_DIR:=patches-$(PKG_VERSION)
endif
ifeq ($(CONFIG_AR7_ATM_FW_VERSION_703),y)
PKG_VERSION:=D7.03.01.00
PKG_MD5SUM:=bc6e9c6adb1be25820c7ee661de8ca7d
PKG_RELEASE:=R2
+PATCH_DIR:=patches-D7.04.03.00
endif
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_RELEASE).tar.bz2