aboutsummaryrefslogtreecommitdiffstats
path: root/package/ar7-atm/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-20 23:48:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-20 23:48:26 +0000
commit2651efbce4d0bcc6035bdd4ad1a90ff0cbec92a6 (patch)
tree331eed3aac4c9cd907ae12202d0f8d3c1ebf7e02 /package/ar7-atm/Makefile
parent35c32933d559e5fe1b9ccae873305ebbd4f22d22 (diff)
downloadupstream-2651efbce4d0bcc6035bdd4ad1a90ff0cbec92a6.tar.gz
upstream-2651efbce4d0bcc6035bdd4ad1a90ff0cbec92a6.tar.bz2
upstream-2651efbce4d0bcc6035bdd4ad1a90ff0cbec92a6.zip
add new ar7 dsl driver (thanks, matteo), mark ar7-2.4 as broken and enable ar7-2.6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7020 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ar7-atm/Makefile')
-rw-r--r--package/ar7-atm/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/package/ar7-atm/Makefile b/package/ar7-atm/Makefile
index 1ff2186fd6..1f41d3b6cd 100644
--- a/package/ar7-atm/Makefile
+++ b/package/ar7-atm/Makefile
@@ -9,19 +9,19 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
-PKG_NAME:=sangam-atm
-PKG_VERSION:=0.1
+PKG_NAME:=sangam_atm
+PKG_VERSION:=07.01.00.10
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PKG_MD5SUM:=90c10702c9c3129e2ad1c01ce3975bf5
+PKG_MD5SUM:=d35e8889ada0f79b3f562bb12dcef0d4
include $(INCLUDE_DIR)/package.mk
define KernelPackage/sangam-atm-annex-a
SUBMENU:=Network Devices
- DEPENDS:=@LINUX_2_4_AR7 +kmod-atm
+ DEPENDS:=+kmod-atm
TITLE:=AR7 ADSL driver (Annex A)
DESCRIPTION:=The AR7 ADSL driver for Annex A
VERSION:=$(PKG_VERSION)+$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
@@ -44,11 +44,13 @@ define Build/Compile
endef
define KernelPackage/sangam-atm-annex-a/install
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/ar0700xx_a.bin $(1)/lib/modules/ar0700xx.bin
+ mkdir -p $(1)/lib/firmware
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/ar0700mp.bin $(1)/lib/firmware/ar0700xx.bin
endef
define KernelPackage/sangam-atm-annex-b/install
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/ar0700xx_b.bin $(1)/lib/modules/ar0700xx.bin
+ mkdir -p $(1)/lib/firmware
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/ar0700db.bin $(1)/lib/firmware/ar0700xx.bin
endef
$(eval $(call KernelPackage,sangam-atm-annex-a))