aboutsummaryrefslogtreecommitdiffstats
path: root/package/alsa/patches
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-08-09 20:36:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-08-09 20:36:05 +0000
commit91a01e41067edb1d08727e7170b2fe76c4859f9c (patch)
tree6e5df70693528290fa1e26ae1a88c32538dec39c /package/alsa/patches
parentd7c8f38007061b0c984785ee3a45ab0ca0da9915 (diff)
downloadupstream-91a01e41067edb1d08727e7170b2fe76c4859f9c.tar.gz
upstream-91a01e41067edb1d08727e7170b2fe76c4859f9c.tar.bz2
upstream-91a01e41067edb1d08727e7170b2fe76c4859f9c.zip
move some webcam/sound related stuff from trunk to packages
SVN-Revision: 12260
Diffstat (limited to 'package/alsa/patches')
-rw-r--r--package/alsa/patches/100-compile_fix.patch19
-rw-r--r--package/alsa/patches/110-cp_command.patch13
-rw-r--r--package/alsa/patches/120-sndfops.patch13
3 files changed, 0 insertions, 45 deletions
diff --git a/package/alsa/patches/100-compile_fix.patch b/package/alsa/patches/100-compile_fix.patch
deleted file mode 100644
index edc15fea89..0000000000
--- a/package/alsa/patches/100-compile_fix.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Index: alsa-driver-1.0.14rc1/include/adriver.h
-===================================================================
---- alsa-driver-1.0.14rc1.orig/include/adriver.h 2007-06-04 13:22:44.887031416 +0200
-+++ alsa-driver-1.0.14rc1/include/adriver.h 2007-06-04 13:22:44.956020928 +0200
-@@ -514,7 +514,7 @@
- #endif /* < 2.6.0 */
-
- /* workarounds for USB API */
--#if defined(SND_NEED_USB_WRAPPER) && (defined(CONFIG_USB) || defined(CONFIG_USB_MODULE))
-+#if 1
-
- #include <linux/usb.h>
-
-@@ -1360,4 +1360,5 @@
- #endif
- #endif
-
-+#undef info /* used in several structs */
- #endif /* __SOUND_LOCAL_DRIVER_H */
diff --git a/package/alsa/patches/110-cp_command.patch b/package/alsa/patches/110-cp_command.patch
deleted file mode 100644
index f9719b5741..0000000000
--- a/package/alsa/patches/110-cp_command.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: alsa-driver-1.0.14rc1/Makefile
-===================================================================
---- alsa-driver-1.0.14rc1.orig/Makefile 2007-06-04 13:22:44.865034760 +0200
-+++ alsa-driver-1.0.14rc1/Makefile 2007-06-04 13:22:45.149991440 +0200
-@@ -115,7 +115,7 @@
- if [ ! -d include/sound -a ! -L include/sound ]; then \
- ln -sf ../alsa-kernel/include include/sound ; \
- fi
-- cp -puvf include/version.h include/sound/version.h
-+ $(CP) include/version.h include/sound/version.h
-
- utils/mod-deps: utils/mod-deps.c
- gcc utils/mod-deps.c -o utils/mod-deps
diff --git a/package/alsa/patches/120-sndfops.patch b/package/alsa/patches/120-sndfops.patch
deleted file mode 100644
index bc43eb5db4..0000000000
--- a/package/alsa/patches/120-sndfops.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: alsa-driver-1.0.14rc1/alsa-kernel/core/sound.c
-===================================================================
---- alsa-driver-1.0.14rc1.orig/alsa-kernel/core/sound.c 2007-07-11 12:15:11.408530571 +0200
-+++ alsa-driver-1.0.14rc1/alsa-kernel/core/sound.c 2007-07-11 12:15:26.421386105 +0200
-@@ -171,7 +171,7 @@
- return err;
- }
-
--static struct file_operations snd_fops =
-+struct file_operations snd_fops =
- {
- .owner = THIS_MODULE,
- .open = snd_open