aboutsummaryrefslogtreecommitdiffstats
path: root/package/acx/patches
diff options
context:
space:
mode:
authorEugene Konev <ejka@imfi.kspu.ru>2007-03-18 14:43:06 +0000
committerEugene Konev <ejka@imfi.kspu.ru>2007-03-18 14:43:06 +0000
commit9eb91471ce026c12a79ec12d99b1458e54f7dd01 (patch)
tree14f774fa3950df4c7bd9fb91209778e17fb441fd /package/acx/patches
parent259c114526589410cf52dd270afa1aff10ff70db (diff)
downloadupstream-9eb91471ce026c12a79ec12d99b1458e54f7dd01.tar.gz
upstream-9eb91471ce026c12a79ec12d99b1458e54f7dd01.tar.bz2
upstream-9eb91471ce026c12a79ec12d99b1458e54f7dd01.zip
Add acx package
SVN-Revision: 6605
Diffstat (limited to 'package/acx/patches')
-rw-r--r--package/acx/patches/001-no-reset.diff18
-rw-r--r--package/acx/patches/002-disable-usb.diff21
2 files changed, 39 insertions, 0 deletions
diff --git a/package/acx/patches/001-no-reset.diff b/package/acx/patches/001-no-reset.diff
new file mode 100644
index 0000000000..c79c2456a6
--- /dev/null
+++ b/package/acx/patches/001-no-reset.diff
@@ -0,0 +1,18 @@
+--- acx-20060521.orig/pci.c 2007-01-25 15:43:48.000000000 +0700
++++ acx-20060521/pci.c 2007-01-25 15:43:48.000000000 +0700
+@@ -906,10 +906,13 @@
+
+ acx_lock(adev, flags);
+
+- acxpci_l_reset_mac(adev);
+-
+ ecpu_ctrl = read_reg16(adev, IO_ACX_ECPU_CTRL) & 1;
+ if (!ecpu_ctrl) {
++ acxpci_l_reset_mac(adev);
++ ecpu_ctrl = read_reg16(adev, IO_ACX_ECPU_CTRL) & 1;
++ }
++
++ if (!ecpu_ctrl) {
+ msg = "eCPU is already running. ";
+ goto end_unlock;
+ }
diff --git a/package/acx/patches/002-disable-usb.diff b/package/acx/patches/002-disable-usb.diff
new file mode 100644
index 0000000000..4eb01829b7
--- /dev/null
+++ b/package/acx/patches/002-disable-usb.diff
@@ -0,0 +1,21 @@
+--- acx-20070101.orig/Makefile 2007-01-25 17:09:24.000000000 +0700
++++ acx-20070101/Makefile 2007-01-25 17:09:41.000000000 +0700
+@@ -1,7 +1,7 @@
+ obj-m += acx.o
+
+ acx-obj-y += pci.o
+-acx-obj-y += usb.o
++#acx-obj-y += usb.o
+
+ acx-objs := wlan.o conv.o ioctl.o common.o $(acx-obj-y)
+
+--- acx-20070101.orig/acx_config.h 2007-01-25 17:21:05.000000000 +0700
++++ acx-20070101/acx_config.h 2007-01-25 17:21:08.000000000 +0700
+@@ -1,6 +1,6 @@
+ /* temporary hack until proper Kconfig integration */
+ #define CONFIG_ACX_PCI 1
+-#define CONFIG_ACX_USB 1
++/*#define CONFIG_ACX_USB 1*/
+
+ #define ACX_RELEASE "v0.3.36"
+