aboutsummaryrefslogtreecommitdiffstats
path: root/package/acx-mac80211
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2013-06-19 21:37:56 +0000
committerHauke Mehrtens <hauke@openwrt.org>2013-06-19 21:37:56 +0000
commit71915880cdf4ecf10a5f302e81c446acbeffd836 (patch)
treecd4a2f6827e4b3f64cf082de220dee551f156a0c /package/acx-mac80211
parent7c6fb560a9a0bfa4a7331ddc13324094662525af (diff)
downloadupstream-71915880cdf4ecf10a5f302e81c446acbeffd836.tar.gz
upstream-71915880cdf4ecf10a5f302e81c446acbeffd836.tar.bz2
upstream-71915880cdf4ecf10a5f302e81c446acbeffd836.zip
acx-mac80211: make it compile with the new backports mac80211
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36976 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/acx-mac80211')
-rw-r--r--package/acx-mac80211/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/package/acx-mac80211/Makefile b/package/acx-mac80211/Makefile
index 30c375eabb..3e4984d59d 100644
--- a/package/acx-mac80211/Makefile
+++ b/package/acx-mac80211/Makefile
@@ -180,6 +180,9 @@ PKG_EXTRA_CFLAGS:= \
$(if $(CONFIG_LEDS_TRIGGERS), -DCONFIG_MAC80211_LEDS -DCONFIG_LEDS_TRIGGERS) \
$(if $(CONFIG_PACKAGE_MAC80211_DEBUGFS), -DCONFIG_CFG80211_DEBUGFS -DCONFIG_MAC80211_DEBUGFS) \
$(if $(CONFIG_PACKAGE_MAC80211_MESH), -DCONFIG_MAC80211_MESH) \
+ -DBACKPORTED_KERNEL_NAME=\\\"$(PKG_SOURCE)\\\" \
+ -DBACKPORTED_KERNEL_VERSION=\\\"$(PKG_SOURCE_VERSION)\\\" \
+ -DBACKPORTS_VERSION=\\\"unknown\\\" \
define Build/Compile
$(MAKE) -C "$(LINUX_DIR)" \
@@ -188,12 +191,13 @@ define Build/Compile
SUBDIRS="$(PKG_BUILD_DIR)" \
$(PKG_EXTRA_KCONFIG) \
EXTRA_CFLAGS="$(PKG_EXTRA_CFLAGS) -DCONFIG_ACX_MAC80211_VERSION=\"KERNEL_VERSION(3,10,0)\"" \
- LINUXINCLUDE="-I$(STAGING_DIR)/usr/include/mac80211/uapi -I$(STAGING_DIR)/usr/include/mac80211 \
+ LINUXINCLUDE="-I$(STAGING_DIR)/usr/include/mac80211-backport/uapi -I$(STAGING_DIR)/usr/include/mac80211-backport \
+ -I$(STAGING_DIR)/usr/include/mac80211/uapi -I$(STAGING_DIR)/usr/include/mac80211 \
-I$(LINUX_DIR)/include -I$(LINUX_DIR)/include/$(LINUX_UAPI_DIR) \
-I$(LINUX_DIR)/include/generated/uapi/ -Iarch/$(LINUX_KARCH)/include \
-Iarch/$(LINUX_KARCH)/include/$(LINUX_UAPI_DIR) \
-include generated/autoconf.h \
- -include linux/compat-2.6.h" \
+ -include backport/backport.h " \
V="$(V)" \
modules
endef