aboutsummaryrefslogtreecommitdiffstats
path: root/package/acx-mac80211
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-07 23:16:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-07 23:16:37 +0000
commiteaca6d017264a9501262d76f4d7b8ec494fee1d2 (patch)
tree06025ca4808e95d8f7985e1597cbf46a65f1f2a0 /package/acx-mac80211
parentd25c8f1b4f79bf74288860274f59f4429416f3a8 (diff)
downloadupstream-eaca6d017264a9501262d76f4d7b8ec494fee1d2.tar.gz
upstream-eaca6d017264a9501262d76f4d7b8ec494fee1d2.tar.bz2
upstream-eaca6d017264a9501262d76f4d7b8ec494fee1d2.zip
fix acx-mac80211 compile with older kernels
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9512 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/acx-mac80211')
-rw-r--r--package/acx-mac80211/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/acx-mac80211/Makefile b/package/acx-mac80211/Makefile
index effa403a25..a3c16ec093 100644
--- a/package/acx-mac80211/Makefile
+++ b/package/acx-mac80211/Makefile
@@ -42,6 +42,7 @@ $(STAMP_BUILT): $(DL_DIR)/$(PKG_FW_NAME)
$(DL_DIR)/$(PKG_FW_NAME):
$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_FW_NAME)" "$(PKG_FW_MD5SUM)" $(PKG_FW_URL)
+ifneq ($(findstring 2.6.23,$(LINUX_VERSION)),)
PKG_EXTRA_KCONFIG:= \
CONFIG_ACX_MAC80211=m \
CONFIG_ACX_MAC80211_PCI=m \
@@ -50,7 +51,7 @@ $(DL_DIR)/$(PKG_FW_NAME):
$(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=m,%,$(filter %=m,$(PKG_EXTRA_KCONFIG)))) \
$(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=y,%,$(filter %=y,$(PKG_EXTRA_KCONFIG)))) \
- define Build/Compile/it
+ define Build/Compile
$(MAKE) -C "$(LINUX_DIR)" \
ARCH="$(LINUX_KARCH)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
@@ -62,14 +63,13 @@ $(DL_DIR)/$(PKG_FW_NAME):
V="$(V)" \
modules
endef
+else
+ override CONFIG_PACKAGE_kmod-acx-mac80211=
+endif
define Build/Configure
endef
-define Build/Compile
-$(call Build/Compile/it)
-endef
-
define KernelPackage/acx-mac80211/install
$(INSTALL_DIR) $(1)/lib/firmware
$(INSTALL_DATA) $(DL_DIR)/$(PKG_FW_NAME) $(1)/lib/firmware/