aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-01 14:01:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-01 14:01:31 +0000
commitc361ae08ca064a3d6bd8f026be8c0c1971512c7b (patch)
tree612dfc1153262f1936d4baa61aba148f4cb87c5c /package/Makefile
parent7ac23daea98c0f66520ed9ebc1a86204910de384 (diff)
downloadupstream-c361ae08ca064a3d6bd8f026be8c0c1971512c7b.tar.gz
upstream-c361ae08ca064a3d6bd8f026be8c0c1971512c7b.tar.bz2
upstream-c361ae08ca064a3d6bd8f026be8c0c1971512c7b.zip
allow people to add files to the rootfs by putting them in $(TOPDIR)/files/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5685 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index e0483deb59..34eba4e3b1 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -55,6 +55,9 @@ install-targets: base-files-install $(INSTALL_PACKAGES)
install:
rm -rf $(BUILD_DIR)/root
$(MAKE) install-targets
+ @if [ -d $(TOPDIR)/files ]; then \
+ $(CP) $(TOPDIR)/files/. $(BUILD_DIR)/root; \
+ fi
@( \
cd $(BUILD_DIR)/root; \
for script in ./etc/init.d/*; do \