aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-08-14 16:22:31 +0000
committerNicolas Thill <nico@openwrt.org>2005-08-14 16:22:31 +0000
commitbd316bc9b2a8f338831dfb7ff6844f430984f826 (patch)
treee6cfa329345a13e4a2480969c959626d5c1ceb02 /package/Makefile
parent5c6887810a97406eeebf124a59c9a224fa83ea98 (diff)
downloadupstream-bd316bc9b2a8f338831dfb7ff6844f430984f826.tar.gz
upstream-bd316bc9b2a8f338831dfb7ff6844f430984f826.tar.bz2
upstream-bd316bc9b2a8f338831dfb7ff6844f430984f826.zip
change config screen,
fix build dependencies, make -mod-xml use expat instead of builtin xml impl, bump release number. git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1666 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/package/Makefile b/package/Makefile
index e855e6f4ec..0344b79f44 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -105,7 +105,7 @@ package-$(BR2_PACKAGE_OPENVPN) += openvpn
package-$(BR2_PACKAGE_OSIRIS) += osiris
package-$(BR2_PACKAGE_PARPROUTED) += parprouted
package-$(BR2_PACKAGE_PCRE) += pcre
-package-$(BR2_PACKAGE_PHP4) += php4
+package-$(BR2_COMPILE_PHP4) += php4
package-$(BR2_PACKAGE_PICOCOM) += picocom
package-$(BR2_PACKAGE_PMACCT) += pmacct
package-$(BR2_PACKAGE_POPT) += popt
@@ -250,6 +250,7 @@ ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
openvpn-compile: lzo-compile
endif
+php4-compile: openssl-compile zlib-compile
ifneq ($(BR2_PACKAGE_PHP4_MOD_GD),)
php4-compile: libgd-compile libpng-compile
endif
@@ -259,9 +260,6 @@ endif
ifneq ($(BR2_PACKAGE_PHP4_MOD_MYSQL),)
php4-compile: mysql-compile
endif
-ifneq ($(BR2_PACKAGE_PHP4_MOD_OPENSSL),)
-php4-compile: openssl-compile
-endif
ifneq ($(BR2_PACKAGE_PHP4_MOD_PCRE),)
php4-compile: pcre-compile
endif
@@ -271,6 +269,9 @@ endif
ifneq ($(BR2_PACKAGE_PHP4_MOD_SQLITE),)
php4-compile: sqlite2-compile
endif
+ifneq ($(BR2_PACKAGE_PHP4_MOD_XML),)
+php4-compile: expat-compile
+endif
pmacct-compile: libpcap-compile
ifneq ($(BR2_PACKAGE_PMACCT_MYSQL),)