aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-05-27 05:24:20 +0000
committerNicolas Thill <nico@openwrt.org>2005-05-27 05:24:20 +0000
commitb4cf2b7c8a69c2ec2c063e68f044a4a6081cc09f (patch)
tree7a06e39bb67271c31f8f447c1f81dd40035a95fd /package/Makefile
parentd93e77d40f266b63b3ec52d86c673fe7dd6ccc84 (diff)
downloadupstream-b4cf2b7c8a69c2ec2c063e68f044a4a6081cc09f.tar.gz
upstream-b4cf2b7c8a69c2ec2c063e68f044a4a6081cc09f.tar.bz2
upstream-b4cf2b7c8a69c2ec2c063e68f044a4a6081cc09f.zip
Ack freeradius package configuration,
Don't build with features that were not selected git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1073 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index f6cf6dec22..a26411ddb4 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -122,7 +122,6 @@ arpwatch-compile: libpcap-compile
cyrus-sasl-compile: openssl-compile
dropbear-compile: zlib-compile
fprobe-compile: libpcap-compile
-freeradius-compile: libtool-compile mysql-compile openldap-compile openssl-compile postgresql-compile
kismet-compile: uclibc++-compile libpcap-compile ncurses-compile
lcd4linux-compile: ncurses-compile
libgd-compile: libpng-compile
@@ -157,6 +156,17 @@ ifneq ($(BR2_PACKAGE_ASTERISK_MYSQL),)
asterisk-compile: mysql-compile
endif
+freeradius-compile: libtool-compile openssl-compile
+ifneq ($(BR2_PACKAGE_FREERADIUS_MOD_LDAP),)
+freeradius-compile: openldap-compile
+endif
+ifneq ($(BR2_PACKAGE_FREERADIUS_MOD_SQL_MYSQL),)
+freeradius-compile: mysql-compile
+endif
+ifneq ($(BR2_PACKAGE_FREERADIUS_MOD_SQL_PGSQL),)
+freeradius-compile: postgresql-compile
+endif
+
openvpn-compile: openssl-compile
ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
openvpn-compile: lzo-compile