aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-08-09 12:11:34 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-08-09 12:11:34 +0000
commit98a9c8bd5be3924ea6ae9edd3018b5b3f49340b1 (patch)
tree7a3507750dff067b4a76c91874242245df44ccf7 /package/Makefile
parenta5fcdc6d79e7d56aebdf445d9719db9d16a48a2c (diff)
downloadupstream-98a9c8bd5be3924ea6ae9edd3018b5b3f49340b1.tar.gz
upstream-98a9c8bd5be3924ea6ae9edd3018b5b3f49340b1.tar.bz2
upstream-98a9c8bd5be3924ea6ae9edd3018b5b3f49340b1.zip
BB: build: consider sub-directories when deploying packages to image with CONFIG_PER_FEED_REPO (#17430)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> Backport of r42041 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42089 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index bf1b16fc9a..0cba878576 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -94,7 +94,7 @@ $(curdir)/install: $(TMP_DIR)/.build
- find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
rm -rf $(TARGET_DIR)
[ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp
- @$(FIND) `sed -e 's|.*|$(PACKAGE_DIR)/&_*.ipk|' $(PACKAGE_INSTALL_FILES)` | sort -u | $(OPKG) install
+ @$(FIND) `sed -e 's|.*|$(PACKAGE_DIR)$(if $(CONFIG_PER_FEED_REPO),/*)/&_*.ipk|' $(PACKAGE_INSTALL_FILES)` | sort -u | $(OPKG) install
@for file in $(PACKAGE_INSTALL_FILES); do \
[ -s $$file.flags ] || continue; \
for flag in `cat $$file.flags`; do \