aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-30 18:55:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-30 18:55:52 +0000
commitf45baccdc5081fc6245c9d567ddb47518f3dc84b (patch)
treedce7c27a867c504bd1f1509244405407154d9da9 /package/Makefile
parent8fcedabfaf95affbbba45bfdbf2627e92fa52ccd (diff)
downloadupstream-f45baccdc5081fc6245c9d567ddb47518f3dc84b.tar.gz
upstream-f45baccdc5081fc6245c9d567ddb47518f3dc84b.tar.bz2
upstream-f45baccdc5081fc6245c9d567ddb47518f3dc84b.zip
improve dependency handling, fix some package makefile bugs
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3843 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/Makefile b/package/Makefile
index 0dc2670174..adeb238d43 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -1,7 +1,7 @@
# Main makefile for the packages
include $(TOPDIR)/rules.mk
include $(TOPDIR)/.config
-include .pkgdeps
+include $(TOPDIR)/.pkgdeps
COMPILE_PACKAGES:=$(patsubst %,%-compile,$(package-y) $(package-m))
INSTALL_PACKAGES:=$(patsubst %,%-install,$(package-y))
@@ -20,7 +20,7 @@ $(STAMP_DIR) $(TARGET_DIR):
$(MAKE) -C $(patsubst %-clean,%,$@) clean
-.pkgdeps: $(TOPDIR)/.pkginfo
+$(TOPDIR)/.pkgdeps: $(TOPDIR)/.pkginfo
@$(TOPDIR)/scripts/gen_deps.pl < $< > $@ || rm -f $@
all: compile