aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-05-16 00:32:57 +0000
committerMike Baker <mbm@openwrt.org>2006-05-16 00:32:57 +0000
commitcd466375e1cff138808173308b7d3d9446fc7303 (patch)
tree88fda948e849796a6d442f04047e3e5de2d32c2d /package/Makefile
parent398ca3a233d6fb0e9b5d30ebcd660007f61e4172 (diff)
downloadupstream-cd466375e1cff138808173308b7d3d9446fc7303.tar.gz
upstream-cd466375e1cff138808173308b7d3d9446fc7303.tar.bz2
upstream-cd466375e1cff138808173308b7d3d9446fc7303.zip
finish up package makefile
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3786 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/package/Makefile b/package/Makefile
index e0bd23c7ec..af746715ba 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -1,13 +1,11 @@
# Main makefile for the packages
include $(TOPDIR)/rules.mk
+include $(TOPDIR)/.config
+include .pkgdeps
+
COMPILE_PACKAGES:=$(patsubst %,%-compile,$(package-y) $(package-m))
INSTALL_PACKAGES:=$(patsubst %,%-install,$(package-y))
-all: compile
-clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
-compile: $(COMPILE_PACKAGES)
-install: base-files-install $(INSTALL_PACKAGES)
-
$(STAMP_DIR) $(TARGET_DIR):
mkdir -p $@
@@ -15,8 +13,19 @@ $(STAMP_DIR) $(TARGET_DIR):
$(MAKE) -C $(patsubst %-prepare,%,$@) prepare
%-compile: $(STAMP_DIR) $(TARGET_DIR)
+ @echo "-> make $@"
$(MAKE) -C $(patsubst %-compile,%,$@) compile
%-clean: $(STAMP_DIR) $(TARGET_DIR)
$(MAKE) -C $(patsubst %-clean,%,$@) clean
+
+.pkgdeps: $(TOPDIR)/.pkginfo FORCE
+ @$(TOPDIR)/scripts/gen_deps.pl < $< > $@ || rm -f $@
+
+all: compile
+clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
+compile: $(COMPILE_PACKAGES)
+install: base-files-install $(INSTALL_PACKAGES)
+
+