aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-05 12:39:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-05 12:39:52 +0000
commita1c781bdae4fbb7466d04ef02e5be85191eb06c1 (patch)
tree6b03cb6970fc37cbfc9c1431cb3e05bba369533a /package/Makefile
parent2bfd91acb25f337e103298a69f490cff87c4b8a3 (diff)
downloadupstream-a1c781bdae4fbb7466d04ef02e5be85191eb06c1.tar.gz
upstream-a1c781bdae4fbb7466d04ef02e5be85191eb06c1.tar.bz2
upstream-a1c781bdae4fbb7466d04ef02e5be85191eb06c1.zip
speed up package prereq check (only run make on those directories that actually contain prereq checks)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4927 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index b9392c0490..b6165b8567 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(TOPDIR)/.config
include $(TOPDIR)/.pkgdeps
-PREREQ_PACKAGES:=$(patsubst %,%-prereq,$(package-y) $(package-m))
+PREREQ_PACKAGES:=$(patsubst %,%-prereq,$(package-prereq))
DOWNLOAD_PACKAGES:=$(patsubst %,%-download,$(package-y) $(package-m))
COMPILE_PACKAGES:=$(patsubst %,%-compile,$(package-y) $(package-m))
INSTALL_PACKAGES:=$(patsubst %,%-install,$(package-y))