aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-31 22:54:21 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-31 22:54:21 +0000
commit48ed3043e3f8b76c77e59a22be92b7e693aaf3fe (patch)
tree7188045b907c7c1c24b4e346bc22b7de53375d73 /package/Makefile
parent1bf3b5183d15b34c55103e95b21bc983da1579bd (diff)
downloadupstream-48ed3043e3f8b76c77e59a22be92b7e693aaf3fe.tar.gz
upstream-48ed3043e3f8b76c77e59a22be92b7e693aaf3fe.tar.bz2
upstream-48ed3043e3f8b76c77e59a22be92b7e693aaf3fe.zip
fix rootfs and init script handling
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8293 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/package/Makefile b/package/Makefile
index 0d74c0d7f3..153ca657b0 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -15,10 +15,11 @@ $(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
$(curdir)/builddirs-install:=. $(sort $(package-y))
$(curdir)/install:=$(curdir)/install-cleanup
-$(curdir)/install-cleanup:
+
+$(curdir)/cleanup:
rm -rf $(BUILD_DIR)/root
- $(MAKE) install-targets
- $(MAKE) preconfig
+
+$(curdir)/rootfs-prepare:
@if [ -d $(TOPDIR)/files ]; then \
$(CP) $(TOPDIR)/files/. $(BUILD_DIR)/root; \
fi
@@ -33,16 +34,19 @@ $(curdir)/install-cleanup:
@-find $(BUILD_DIR)/root -name CVS | $(XARGS) rm -rf
@-find $(BUILD_DIR)/root -name .svn | $(XARGS) rm -rf
@-find $(BUILD_DIR)/root -name '.#*' | $(XARGS) rm -f
-
-$(curdir)/index: FORCE
- (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
+ @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
$(curdir)/flags-install:= -j1
$(eval $(call stampfile,$(curdir),package,prereq))
+$(eval $(call stampfile,$(curdir),package,cleanup))
$(eval $(call stampfile,$(curdir),package,compile))
$(eval $(call stampfile,$(curdir),package,install))
+$(eval $(call stampfile,$(curdir),package,rootfs-prepare))
-$($(curdir)/stamp-install): $($(curdir)/stamp-compile)
+$($(curdir)/stamp-cleanup): $(TMP_DIR)/.build
+$($(curdir)/stamp-compile): $($(curdir)/stamp-cleanup) $(TMP_DIR)/.build
+$($(curdir)/stamp-install): $($(curdir)/stamp-compile) $(TMP_DIR)/.build
+$($(curdir)/stamp-rootfs-prepare): $($(curdir)/stamp-install) $(TMP_DIR)/.build
$(eval $(call subdir,$(curdir)))