aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-03 06:16:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-03 06:16:08 +0000
commit414e3ef71af42ec5a4c18ff0be41f7b794ab28e7 (patch)
treeeed2fdcff73a7374bac56a637ae02b5362877ec7 /package/Makefile
parent304696e31df4478708f59f2c81433339e4634e7f (diff)
downloadupstream-414e3ef71af42ec5a4c18ff0be41f7b794ab28e7.tar.gz
upstream-414e3ef71af42ec5a4c18ff0be41f7b794ab28e7.tar.bz2
upstream-414e3ef71af42ec5a4c18ff0be41f7b794ab28e7.zip
Add quilt integration for packages
make package/<package>-prepare QUILT=1 will apply all patches using quilt Autorebuild will be disabled, so that you can edit all patches in the build dir. When you're done editing patches and everything works, you can call: make package/<package>-refresh That will copy the updated patches from quilt into package/<package>/patches, and remove all old patches. Before the patches are overwritten, the correct order of the patches is verified ('cat series' is compared against 'sort series'). git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7471 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/Makefile b/package/Makefile
index 64c78de5e7..0713e8d23e 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -26,9 +26,9 @@ ifeq ($(QUIET),1)
%-compile %-install: FORCE
$(MAKE) -C $* $(patsubst $*-%,%,$@) || { $(call MESSAGE, "*** $* $(patsubst $*-%,%,$@) failed"); false; }
-%-prepare %-prereq %-download %-clean: FORCE
+%-prepare %-prereq %-download %-clean %-refresh: FORCE
else
-%-prepare %-prereq %-download %-clean %-compile %-install: FORCE
+%-prepare %-prereq %-download %-clean %-compile %-install %-refresh: FORCE
endif
$(MAKE) -C $* $(patsubst $*-%,%,$@)