aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-01 08:21:15 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-01 08:21:15 +0000
commit3312543ae150823972fa25ca7774d17eced7e55c (patch)
treecd7dc226a04809f93a74c608a95f42b7feb0685d /package/Makefile
parent48ed3043e3f8b76c77e59a22be92b7e693aaf3fe (diff)
downloadupstream-3312543ae150823972fa25ca7774d17eced7e55c.tar.gz
upstream-3312543ae150823972fa25ca7774d17eced7e55c.tar.bz2
upstream-3312543ae150823972fa25ca7774d17eced7e55c.zip
fix package/index
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8294 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/Makefile b/package/Makefile
index 153ca657b0..9b400ffeff 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -16,10 +16,10 @@ $(curdir)/builddirs-install:=. $(sort $(package-y))
$(curdir)/install:=$(curdir)/install-cleanup
-$(curdir)/cleanup:
+$(curdir)/cleanup: $(TMP_DIR)/.build
rm -rf $(BUILD_DIR)/root
-$(curdir)/rootfs-prepare:
+$(curdir)/rootfs-prepare: $(TMP_DIR)/.build
@if [ -d $(TOPDIR)/files ]; then \
$(CP) $(TOPDIR)/files/. $(BUILD_DIR)/root; \
fi
@@ -34,6 +34,8 @@ $(curdir)/rootfs-prepare:
@-find $(BUILD_DIR)/root -name CVS | $(XARGS) rm -rf
@-find $(BUILD_DIR)/root -name .svn | $(XARGS) rm -rf
@-find $(BUILD_DIR)/root -name '.#*' | $(XARGS) rm -f
+
+$(curdir)/index: FORCE
@(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
$(curdir)/flags-install:= -j1