aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-14 23:37:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-14 23:37:40 +0000
commit2cf3780bea997e6908ff493f20f04bdb5f128a47 (patch)
treed680bd5375024aa5e8b6a06b999f03a3655f14fc /package/Makefile
parenta4ee82e1988661811cab300e22c38258271e13cb (diff)
downloadupstream-2cf3780bea997e6908ff493f20f04bdb5f128a47.tar.gz
upstream-2cf3780bea997e6908ff493f20f04bdb5f128a47.tar.bz2
upstream-2cf3780bea997e6908ff493f20f04bdb5f128a47.zip
Fix config checks for Image Builder and SDK - only build them when requested.
Clear all packages from bin/packages at the beginning of package/compile when the Image Builder is selected, because the Image Builder can't handle multiple versions of the same package. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6102 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index eafd8cbe6e..cd4304e667 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -50,7 +50,9 @@ prereq: $(PREREQ_PACKAGES)
download: $(DOWNLOAD_PACKAGES)
compile-targets: $(COMPILE_PACKAGES)
compile:
+ @-rm -f $(PACKAGE_DIR)/*.ipk
$(MAKE) compile-targets
+
install-targets: $(INSTALL_PACKAGES)
install:
rm -rf $(BUILD_DIR)/root