aboutsummaryrefslogtreecommitdiffstats
path: root/package/6to4
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-07-05 00:52:10 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-07-05 00:52:10 +0000
commitfc026910611534dcc98204b9ea004afffe1d2ed5 (patch)
treeb9dcf1188512d6086aa51198822eeed332ffea51 /package/6to4
parent5e1e039c459374ac2908318a7bfdad5eac8b0bff (diff)
downloadupstream-fc026910611534dcc98204b9ea004afffe1d2ed5.tar.gz
upstream-fc026910611534dcc98204b9ea004afffe1d2ed5.tar.bz2
upstream-fc026910611534dcc98204b9ea004afffe1d2ed5.zip
[package] 6in4, 6to4: prevent starting the tunnel if kmod-sit is not yet loaded (#9643)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27449 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/6to4')
-rw-r--r--package/6to4/Makefile2
-rw-r--r--package/6to4/files/6to4.hotplug5
2 files changed, 6 insertions, 1 deletions
diff --git a/package/6to4/Makefile b/package/6to4/Makefile
index 77082a4a04..f4831a4905 100644
--- a/package/6to4/Makefile
+++ b/package/6to4/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=6to4
PKG_VERSION:=5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
include $(INCLUDE_DIR)/package.mk
diff --git a/package/6to4/files/6to4.hotplug b/package/6to4/files/6to4.hotplug
index 037abd48f5..1e3d26c418 100644
--- a/package/6to4/files/6to4.hotplug
+++ b/package/6to4/files/6to4.hotplug
@@ -20,6 +20,11 @@ if [ "$ACTION" = ifup ]; then
local wanip=$(find_6to4_wanip "$wandev")
[ -n "$wanip" ] && {
+ lsmod | grep -q ^sit || {
+ logger -t 6to4 "Tunneling driver not loaded yet, deferring action"
+ exit 0
+ }
+
uci_set_state network "$cfg" ipaddr "$wanip"
( ifup "$cfg" )&
}